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0 Foreword 

0.1 Introduction  
 

Congratulations on purchasing the new Perrot Satellite Software. You have the 
most modern modular system which will accommodate any need you may have for 
the automatic control of all important irrigation functions. 
 
 

 

Please read this manual carefully and follow all instructions specified in 
it. This manual will help you to understand the use and operation of the 
whole system and will present all important safety instructions.. 

 

 
 

For safety reasons neither children/young people under 
the age of 16 nor people who have not thoroughly 
acquainted themselves with this manual are allowed to 
operate the system. 

 
 

 Please keep this manual in a safe place! 
 
 
Should you have any questions concerning the programming or specific software 
functions, contact your authorised dealer or our customer service, which can be 
contacted at: 
 
 
 
REGNERBAU CALW GmbH 
Industriestraße 19-29 
 
D-75382 Althengstett 

 
 

Phone: +49-7051 / 162-0 
 
Email: technik@perrot.de 

 
 
Caution: 
This documentation and the corresponding software must not be copied, transferred, modified or 
translated into additional languages without our prior written approval. It is allowed to make a safety 
copy for the user’s personal needs. 
This documentation and the corresponding software have been created in line with the current state of 
technology development. Perrot Regnerbau Calw GmbH can be held liable for subsequent damages 
caused directly or indirectly in association with using this documentation only if serious negligence or 
malice is proven.  
We reserve the right to modify this documentation as well as the hardware and/or the software. 
All trade marks mentioned in this documentation are the property of their owners – even if not 
explicitly specified.  
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0.2 Basic Instructions for Using this Manual  

 
This manual has been designed for both beginners and advanced users. This is why 
we will introduce the operating of the system step by step.  
First we will introduce the basic terminology and definitions, and then one sample 
system on which we will explain how to set up the system and enter data. 
Having all the necessary data and information, we will proceed to actual step by step 
programming and configuring of the system. During the process, you will become 
acquainted with all important points, which will make it easier to configure your 
irrigation based on your own values reflecting your particular needs.  
In addition to these, you will pick up a lot of useful practical tips for working with the 
PERROT irrigation system. 
The following information about the content is provided for advanced users. It 
specifies individual topics, explains terms and shows how particular topics can be 
easily found. 
 
Symbols on the left point out useful information or warnings: 
 

 
This highlights information which may be useful for you in the chapter.  

 

 
This highlights warnings, i.e. important points you must pay attention to! 

 
 
We will proceed the following way: 
 
 

Data collecting 
You must have these values available before you 
start entering them in different data fields. Therefore 
these must be collected first.  

   
 
 
 

Data entering 
In which data field should a particular value be keyed 
in? How to work with it? 

   
 

Configuration of 
operation resources 

You can configure the irrigation control program using 
technical data provided with different operation 
resources. 
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1 Function Description 

1.1 How the Irrigation System Works 

 
You need the following function groups to provide "rain to order”: 
 

Actuators Logics / Control Sensors 

1.2 Actuators 

In order to irrigate a lawn with a pop-up sprinkler, a pump must pump water to it 
through a pipeline. However, as not all sprinklers should start irrigating at the same 
time, there are valves installed between the pump and the sprinklers. The pump and 
the valve are interconnected with a control circuit through a decoder. 
 

1.3 Logics / Control 

All keyed in values, sensor-sent signals and the whole data management are 
logically processed. Different actions are calculated based on these processed data. 
The control system sends commands through valve control units (VCU) and through 
data lines to pump or valve decoders. In case of bidirectional decoders, it then 
receives answers (feedback) through the same system. 
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1.4 Sensors 

The efficiency of all commands sent through the system is checked by pressure and 
flow-metering sensors. In case of an error being reported, it is possible to 
immediately trace back its cause. 
In case of rain or strong wind, the rain/wind sensor sends the corresponding signal to 
the control system, which halts the planned irrigation. 
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2 VCU and Decoder Installation 

 

2.1 Hardware Installation and Master VCU Powering 

Site Preparation for the Master VCU Installation 
 
 The Master VCU must be powered from a SCHUKO socket (=type F 

grounding contact) from which the grounding green/yellow wire must be 
disconnected. Grounding will be done through the Master VCU. 

 
 Plug an adapter with over-voltage protection into the socket. 

  
 Install the Master VCU at a suitable place on the wall. 

Connect the decoder cable to terminals 34/35. 
 If you want to connect more cables (up to 3), use terminals 36/37 and 38/39 

(see the wiring diagram in chapter 2.4). 
 
 Now connect additional external interfaces (such as the Mini Click rain sensor, 

for example) to the corresponding terminals. 
 

2.2 VCU’s Power Supply and Grounding 

 Earth the unit with a grounding strip according to the diagram. 
Place an at least 20m-long grounding strip in a trench at least 70 cm deep 
(see the diagram). The grounding resistance should be smaller than 10 Ohm. 
In case of poor conductivity soil (sand, sand-gravel), use 2 x 20 m conductors. 
Install a potential-balancing strip on the wall inside the building. 
Connect the grounding strip to the potential-balancing strip. 

 Connect this strip to the VCU using a 1×16 mm² yellow/green cable.  
Then connect a grounding cable to the grounding terminal in the VCU and to 
the potential-balancing strip. 

 Grounding equipment ordering code: SB50001. 
 
 There are 2 Schuko sockets on the right side of the VCU. Connect your PC to 

one of them. If you have a monitor equipped with its own Schuko plug, 
connect it to the other socket. You can use any socket to connect a modem (if 
you want to use a modem). 

 
 Plug the VCU power cable plug into the adapter with over-voltage protection, 

which is already plugged into the socket. 
Connect the VCU to the COM 1 serial port of your PC. 

 If your PC features more than one serial port, use the one marked as Port 1, 
COM 1, Ser. 1, A or in a similar way. 
 

 Turn the power on. 
The VCU will confirm the connection with a beep. 
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 The green LED on the VCU is permanently on. 
 The yellow LED blinks if: 
 

 The Master VCU is communicating with the PC through the serial 
interface  
   & 

 Perrot Satellite has been started  
   & 

 The Master VCU is NOT in a passive state in the Setup > Satellites 
menu (see chapter 5.4). 
 

 The red LED must be off. 
  

If the red LED is on, there is an error in the decoder cable. 
 
 

Check all the decoder cables and connectors. 
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2.3 Networking of Satellites to Master VCU 

Up to 250 stations can be controlled with the Master VCU. More stations (up to 2000) 
can be controlled through satellite VCUs connected to the Master VCU (up to 7 
Satellites can be connected to the VCU). 
The following must be observed in connecting: 
 

a) Power supply and grounding  
 Grounding 

If the Master VCU is installed in the immediate vicinity of a Satellite VCU, 
grounding can be bridged from the Master to the Satellite. 
If these units are far apart, each (Master and Satellite) must be grounded 
separately – see chapter 2.2. 

 Connect the Satellite to its own power supply socket – in the same way as 
the Master VCU (see chapter 2.2). 

 
b) Communication 
The PC sends orders to the Master VCU, which forwards them to Satellite 1, from 
Satellite 1 to Satellite 2, etc.   

 
In order to communicate like this, the Master must be interconnected with the 
Satellites with one communication cable. Please respect the following points: 
 Use a shielded twisted-pair cable  

(such as NYCY 2×1.5/1.5mm²) 
 minimum cable gauge (cross section) for a distance of: 
 1000 m:  1.5 mm² 
 2500 m: 2.5 mm² 

 
Setting up the DIP switches (only in Satellites) 

 Satellite 1: DIP 2 is in position 1, all the others are in position 0 
 Satellite 2: DIP 1 is in 1, DIP 2 is in 1, all the others are in 0 
 Satellite 3: …..etc.  

See the following drawing.  
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Wiring Diagram for RS 485 Communication 
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2.4 VCU Wiring Diagram  
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2.5 Decoder Wiring Diagram  

 
 
 

 

 Up to 250 decoders can be connected to each VCU. 
 Each VCU has a separate cabling system and MUST NOT be 

interconnected with another VCU through a decoder cable. 
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A) Decoder Wiring for Controlling One Coil  

 
 
 
B) Decoder Wiring for Controlling 2 Coils 
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Decoder Wiring for Controlling 2 Coils (serial connection) 
 

 
 

 

Coils are to be serial-connected to the decoder. This will achieve the best 
coil operation. 
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3 Software Installation 

3.1 Preparation of PC for installation of Perrot Satellite 

Check which operating system of Win7 is installed on your PC: 
 Under “Start / Control Panel / System” you can look up whether your operating 

system works with 32 or 64 bit. This information will be required later for the 
installation of the SQL server. 

 
 
 

3.2 Requirements on PC and operating system 

Following minimum requirements are needed for the installation of Perrot Satellite: 
 AMD Athlon 64 or Pentium 4, min. 1 GHz 
 Min. 1,024 GB RAM, approx. 40 GB memory on hard drive 
 Operating system Windows 7 Professional SP1 
 Microsoft Internet Explorer until version 11 
 Serial interface RS 232 (COM1) for the connection with the valve control unit 
 Network interface card: Ethernet 100 Mbit 
 VGA colour screen, resolution 1024 x 768  

(resolution when using laptop 1280 x 800) 
 Optional: remote control via smartphone is only possible with DSL connection  

using a fixed IP address 
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3.3 Order of installation 

Please keep the following order of installation! 

3.3.1 SQL-Server  

 Please place the Perrot Satellite CD into the drive for the installation of the 
SQL server. Open the CD via the Windows Explorer and proceed opening the 
“SQL Setup” folder. 

 

 Please make sure to choose the right file for your operating system. Open the 
corresponding file with a double click and follow the instructions on the screen. 
32 bit system, file: „en_sql-server_2008_r2_express_x86“ 
64 bit system, file: „SQLEXPR_x64_ENU“ 
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 Select „New Installation or Add Features to an Existing Installation” in the 
SQL server installation center. 

 

 Accept the license conditions by putting a check at the field „I accept the 
license terms“ and click on the button “Next”. 

 
 Proceed with “Next”. 
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 Proceed with “Next”. 

 
 

 Proceed with “Next”. 

 
 

 Once you reach the  „Database Engine Configuration“ change the 
“Authentication Mode” to the setting “Mixed Mode” and insert the following 
passwords: 
Enter password: satellite 
Confirm password: satellite 
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 Proceed with a click on „Next“. 

 
 

 Proceed with „Next“. 
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 Complete the installation with „Close“. 
 All other open windows need to be closed manually. 

 

 

3.3.2 IIS (Internet Information Service) 

 Follow the menu point „Start / Control Panel” and open “Programs and 
Functions” with a double click. 

 
Select „Activate and Deactivate Functions of Windows”. 
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 Open the sub-point at „Internet Information Service / WWW Services / 

Application Development for Features” by clicking on the plus-sign. Tick 
the box at „ASP.NET“. The two settings „ISAPI“ and „NET“ will get ticked 
automatically. Confirm with “OK”. 
Close all open windows and restart the PC. 

 

3.3.3 Perrot Satellite  

 Re-open the Perrot Satellite CD in the Windows Explorer and open the folder 
named „Perrot Satellite Setup“. 
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 Open the file „CreateSatelliteDb“ with a double click. 

 

 Press any button on your keyboard to close the following window 
automatically. 

 
 

 Open the next file “PerrotSatelliteSetup“ with a double click. 
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 Proceed with “Next”. 

 
 

 Change the settings from „Everyone“ to “Just me” and then click “Next”. 

 
 

 Proceed with “Next”. 
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 To complete the installation select „Close“. 

 
 

 In the next step the SGV server will be installed. Open the file „SVG View“ 
with a double click. 

 
 

 Complete the installation with „Close“ and close all open windows. 

 
 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 28 / 180 

 

3.3.4 WebSatellite  

 Re-open the Perrot Satellite CD in the Windows Explorer and open the folder 
„WebSatelliteSetup“. 

 

 Open the file „WebSatelliteSetup“ with a double click to start the installation. 

 
 

 Once the installation has been completed, the window will close automatically. 
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 Open the Windows Start Button, insert “IIS” in the search bar and press enter. 

Select the “Internet Information Services (IIS) Manager” which appears 
under “Programs”. 

 
 

 Alternatively the file can also be opened by following the menu points “Start / 
Control Panel / Administration / IIS Manager”. 
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 Click on the plus-sign to open the sub-menus on the left side and select „Default 

Web Site“. 

 
 

 With the right mouse button click on „Default Web Site“ and select „Remove“. 
Confirm with „Yes“. 
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  Select  „Sites“ with the right mouse button and choose the menu point „Add 
Website“. 

 
 

 As “Sitename” insert „WebSatellite“ and proceed with a click on the button “…” 
besides the field “Physical Path“. 

 
 

 At “Computer / Local Data Storage (C:) / Perrot Satellite” select the folder 
”websatellite” and confirm with “OK”. 
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 The newly generated folder now shows up under the point „Sites“. Close all 
windows. 

 
 

3.3.5 Setting up Internet Explorer  

 Start Internet Explorer. 
 Go to the following menu path: Tools > Internet Options > General > 

Settings > Check for newer versions of stored pages and choose the 
"Every time I visit the webpage” option. 
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Disk space 

History memory 
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To provide enough hard-disc space for working, it is recommended to use 
the values of the Disk space  and the Days to keep pages in history as 
indicated in the previous screenshot. Then confirm your selection by 
clicking the               button. 

 
 
 

 

3.3.6 Troubleshooting 

If the creation of the Perrot Satellite database fails, then restart the computer. After 
the restart, check the right corner of the Windows status bar and make sure you can 
see this SQL server icon:        Run the "CreateSatelliteDB.bat" program again. 
 

3.3.7 Language Setup 

1. Perrot Satellite is a web-based program, which can be used for remotely 
controlled applications. For this reason it consists of two main parts: 
 
 The first part is Satellite Browser, which provides the user interface. 
 The second part is Perrot Satellite, which provides communication with the 

VCU. 
 
 

2. Language Selection 
 
2.1. Language Selection for Satellite Browser 

 
 Satellite Browser runs and is controlled under Internet Explorer. Therefore 

the language selection also must be made in Internet Explorer. 
 To select your required language, open Internet Explorer, go to the menu 

and choose: Tools > Internet Options. 
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 Click the Languages button and choose the required language from the list 
or use the Add... button to add it to the list. Before that make sure that 
Perrot Satellite supports your language. 

 
 

2.2  Language Selection for the Perrot Satellite 
 

 Perrot Satellite is controlled from Windows, therefore the language 
selection must be done in Windows settings. Click Start > Settings > 
Control Panel > Regional and Language Options. 

 

   
 

 Go the Regional Options tab and choose the required language from the 
combo-box. Before that, make sure that Perrot Satellite supports the 
language required by you. 
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3. Recommendations for the language settings: 
 
3.1 Language settings at a local (client) PC, i.e. the PC is directly connected 
to the VCU:  
 
 In this case, Satellite Browser and Perrot Satellite must have the same 

language selected.  
 
3.2 Language settings at a remote PC:  

In this case, you must select the same language for Satellite Browser as 
already selected in Perrot Satellite.  
Other settings might cause communication problems. 

 

3.4 Checking the Communication between PC, Master VCU & Satellites  

To check the correct connections of all interfaces, run the Perrot Satellite program 
(see chapter 4) and go to the following menu path: Setup > Satellites > Satellite. 

 
 
After you have keyed in all necessary Master VCU data and possible satellite data 
(see chapter 5), activate the Master VCU by removing the tick from the "Inactive" 
box. 
 
The go to the Service > Satellite > General menu: 
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If the Net consumption value is higher than 0, connection to the PC has been 
established.  
You can also check that the connection has been established by means of the yellow 
LED on the Master VCU which must be blinking; and/or on the same screen in the 
Digital section where this function is signalled. 

Signalling 
LED 

Net consumption 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 38 / 180 

 

3.5 Uploading the VCU Software  

You need to have the "technician" user rights to upload or update the VCU software. 
Perform the software upload only if: 

a) you need to update the system from Greenkeeper to Perrot Satellite, 
b) VCU software has "frozen" (this happens very rarely), 
c) the manufacturer supplies a new software version. 
 The current Perrot Satellite software version (1.016) can be displayed 

under Service > Satellite > General > Program version: 
 Program version: 2.030 
 Active Prom: Flash 
 Product information: Perrot Sat VCU2005.07.28 V.2.03 

 
 

 
 
 
Before uploading software to the VCU, the VCU must be switched to the "Inactive" 
mode. 
 
You can do so in the Setup > Satellites > Satellite menu by ticking the "Inactive" 
box. 
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Proceed as follows in the Service > Satellite > Programming menu: 

1. Select the satellite to program. 
2. Click the File combo box and choose PE_Main.HEX.  
3. Start the software upload by clicking the Program button. 
4. The Programming status will change from "Passiv" to "Deleting" and then to 

"Programming". 
5. The blue strip shows the uploading progress. 
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Once the uploading procedure is complete, you can remove the tick from the 
Inactive box of the corresponding VCU under the Setup > Satellites > Satellite 
menu.  
 

 
 
Now your PC should communicate with the VCU. You can check it the following 
ways: 

 The yellow LED on the VCU is blinking.  
 The voltage and current values (Net consumption) of the VCU under the 

Service > Satellite > General menu are displayed. If no connection has 
been established, both these values will be 0 (zero).  

 No communication error is displayed in the Perrot Satellite status line. 
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4 Working with Perrot Satellite 

Perrot Satellite is a WEB-based irrigation program. For this reason it consists of two 
parts: 

1. Perrot Satellite 
2. Satellite Browser 
 

Perrot Satellite is the irrigation software itself, in which: 
 all data is documented 
 irrigation programs are created 
 calculations are performed and applied. 

 
This program part must always be active during irrigation. 
 

 

We recommend:  
To have Perrot Satellite running continuously throughout the irrigation 
season. 

 
Satellite Browser is needed to open menus and corresponding screens in which data 
is displayed or entered. This is done by means of Internet  Explorer as a user 
interface. Perrot Satellite can be controlled locally or remotely by any PC connected 
to the Internet. In order to control the software remotely, you need to create access 
rights (see chapter 9). 

4.1 Starting Perrot Satellite  

 

  
 

 
To start the Perrot Satellite application, double click the "Perrot Satellite" icon. 

Satellite Browser 

Program icons: 

Perrot Satellite 
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A small window will open.  
The left part of the status bar gives information on Perrot Satellite current status: 
 Starting… after starting the application 
 Started when the application is active  
 Stopped when the application is stopped/interrupted. 

 

 
 
You can stop and exit the program by means of the corresponding items under the 
File menu. 
 

 

The "Satellite Browser" user interface program must be closed before 
exiting the Perrot Satellite program. Perrot Satellite must always indicate 
"started" before you open Satellite Browser. 

 

Perrot Satellite window 

Status bar 
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4.2 Starting Satellite Browser (user interface program)  

  
 
In order to work with Perrot Satellite, you must start Satellite Browser, which works 
as a user interface. You do so by double-clicking the "Perrot Satellite" icon. 
 

 
 
The browser opens the initial logon screen in which all users must key in their 
username and password. 

Satellite Browser 
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After the initial installation, the software has the following user with the administrator 
user rights pre-programmed: 
 Username:  Perrot 
 Password: Perrot 

Once logged-in the user can use Perrot Satellite without any limitations. 
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4.3 Creating a User  

 
You need to have "technician" privileges to create a new user. 

 

To create a new user, proceed as follows: 
In the main menu: 
 

1. Setup  

 
User 

  
Go to menu, Setup > User. 
 

 

 

 

2. 

 

 

Enter a username.  

 
Beware of capital/small letters (the username is case sensitive). 

 

3. 

 

 

Enter a password. 

 
Beware of capital/small letters (the password is case sensitive). 

 

4. 
User 
rights 

 

Choose a user type (privileges). 

 

Select the required level of user rights for the newly created 
user in the Privilege combo box. 

 

5. 
 

New 
By clicking the New button you can save your newly created data and 
display it in the Edit user table. 
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If you want to protect the program from unauthorised access, delete the 
default "Perrot" user and create your own user with "technician" privileges.

 

4.4 Overview of Technician, Super-user and User Rights 

The following table presents an overview of access rights granted to different users 
to access different menus: 

Main menu Submenu Tab User Super-user Technician

Setup 

Course 

Courses   X X 
Valve collections   X X 
Valve collection   X X 
Settings   X X 

Satellites 
Satellite   X X 
Settings   X X 

Hydraulics 

Pump system   X X 
Pumps   X X 
Pump   X X 
Groups   X X 
Sectors   X X 
Options   X X 

Valves 
Selection names   X X 
Valves   X X 
Valve   X X 

Options 
Control   X X 
Emergency call   X X 

User User     X 

Programs 
Valves Edit X X X 

Valve collections Edit X X X 
Manual Edit X X X 

Irrigation 

Schedule 
Control X X X 
Edit X X X 
Single program X X X 

Surveillance 
Overview X X X 
Details X X X 

Parameters Edit X X X 

Reports Irrigation 
Irrigation programs X X X 
Yearly X X X 
Snapshot X X X 

Service 
Satellite 

General     X 
Decoders     X 
Decoder Test     X 
Log     X 
Programming     X 

Error handling Acknowledge     X 
Application Log     X 
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4.5 Explanation of Screen Sections  

 
 
 

 
 
 

 Menu bar with the main menu and submenus 
 Submenu tabs  
 System reports (log) 
 Perrot Satellite status line 
 Area for displaying and/or entering data 
 
User Interface Description 
 
 Menu bar with the main menu and submenus 
You can open the main menu items by clicking them. The corresponding submenu 
will open for each of them. 
Menus are grouped by their functions. 
 
 Submenu tabs  
Each submenu contains one or more tabs (representing screens) which are arrayed 
horizontally. 
 
 System reports (log) 
This box lists all events generated by the program control, for example: 
 Switching on and off different irrigation programs, decoders, pumps, etc. 
 System errors such as communication errors, too high electrical current value, 

etc. 
 Messages from the weather station and from all connected sensors. 

  

 

 

 
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 Perrot Satellite status line 
The following states can appear in the status line: 
 Started: when the program is in the auto mode 
 Active: when an irrigation program is running 
 Stopped: when the auto mode is off 
 Weather: if irrigation has been interrupted by the weather station 
 Error: if an error has occurred  

 
 Area for displaying and/or entering data 
The user interface itself in which the user can enter data, create irrigation programs 
and see entered or calculated values. 
 

 
You can use the  function key (or the Full Screen button) while 
working with Satellite Browser. This will help you to see all the buttons and 
controls on each screen. (Please try this function to fully understand.) 
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5 Entering the Basic Data 

 

5.1 Structuring a Project  

The versatile Perrot Satellite structure provides an individual approach to entering 
your project and equipment data. The area to be irrigated can be divided from the 
point of view of the game (golf) or servicing. The user can decide whether to leave 
the whole area as one or whether to divide it into sub-areas to make it easier to work 
with. 
 
Perrot Satellite offers dividing the area into up to 10 sub-areas and 10 pump 
systems, regardless of the irrigation programs running simultaneously or sequentially. 
 
This division into sub-areas is crucial for the future control of the irrigation technology 
and for creation of irrigation programs. For this reason, we will explain the pros and 
cons of different alternatives – and use the following examples for clearer 
understanding.  
 
You as the user need to have a clear idea of what you want to achieve before you 
start entering data and by this structuring the project. 
 
Alternative 1  

 
 All valves are assigned to only one area (course). 
 All valves are fed from a single pump system (station). 
 Different irrigation programs must run sequentially (not simultaneously). 
 Example: a course with 9 or 18 holes and 1 pump station.  
 This is the simplest alternative (identical with the previous Greenkeeper Win 

software). 
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Alternative 2   

 
 Valves are divided into 2 courses (sub-areas). 
 Each course is fed by its own pump system (station) 
 Irrigation programs can run simultaneously for both courses 
 Example: the existing 9/18-hole course has been extended by an additional 

9/18-hole (hydraulically separate) course. 
 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 51 / 180 

 
Alternative 3 

 
 Valves are divided into 2 courses (sub-areas). 
 Both courses are fed by a shared pump system (station).  
 Irrigation programs for different courses must run sequentially (not 

simultaneously). 
 Example: the existing 9/18-hole course has been extended (and the pump 

system enlarged).  
Advantage:   Valve data are easy to see as on one area  
Disadvantage: One piping line is not used => higher pressure loss 

 

 

 Each area must have a pump system assigned to it. 
 If more than 300 valves (decoders) are used, it is recommended to 

divide the area to make it easier to survey and control. 
 The pump system can also be divided into 2 virtual systems to create 

smaller and easier-to-survey areas. 
 In case of two or more hydraulically separate systems, it is 

recommended to divide the area into corresponding sub-areas. Only 
then will you be able to irrigate them simultaneously. 

 
The number of areas (courses) is not dependant on the number of VCUs.  
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5.2 Entering the Irrigation Parameters 

 

5.2.1 Irrigation Process 

Based on the entered data, Perrot Satellite calculates suitable irrigation procedure 
and time. All needed commands are transferred via the PC serial port to the valve 
control unit (VCU). Once an irrigation program is activated, the VCU forwards these 
commands through a decoder to pumps and/or valves. The VCU also receives 
signals from sensors and forwards them to the control unit for further processing. 
 

 

Further details concerning different components and their functioning will be 
explained later in this manual. 

 

5.2.2 What Data Do I Need for the Program? 

Before you start an irrigation program, you have to enter all necessary data 
concerning different components of the irrigation system. In order to do so, have 
manufacturer's data sheets for these components as well as a diagram with an 
overall view of the area to be irrigated available. 
 

 
Enter only the original values as specified by the manufacturer!  

  
The following data will be needed for individual system components: 
 

Component Parameter 
Basic 
value 

Note 

Pump Pump capacity m³/h  See the pump data sheet 

 Pump identification  Pump name 

 Decoder No.  Which decoder is the pump connected to? 

 Bidirectional data flow?  Can the decoder send signals back to the 
pump? 

 Satellite No.  Which VCU is the pump connected to? 

 Efficiency in %  To what extend should the pump be used? 

 
Valve Flow in m³/h  See the valve data sheet 

 Irrigated (covered) area 
in m² 

 To be determined from the area irrigated 
by all connected sprinklers. 

 Valve identification  Valve name 

 Decoder No.  Which decoder is the valve connected to? 

 Satellite-No.  Which VCU is the valve connected to? 

 Bidirectional data flow?  Is the connected decoder bidirectional? 

 
Flow sensor?  

Is the flow through the valve monitored by 
a sensor? The sensor may be installed at 
the sprinkler. 
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External Signal Providers 

Component Parameter 
Basic 
value 

Note 

Sensor    

    

    

    

    

    

    

 
This documentation contains a component form in which all necessary data can be 
recorded. 
 

 
 

5.2.3 Irrigated Area Example 

To create a foundation for later entering, we will explain the procedure on this 1-hole 
training golf course example.  

1-hole training course 
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The irrigation system has the following components installed: 
Perrot Regnerbau Calw GmbH Anlage: 1-Loch Übungsgolfplatz Auftrags-Nr.:
Industriestraße 19-29 Ort: Golfhausen Bereich:
D-75382 Althengstett

BMK = Betriebsmittelkennzeichen

BMK
Pos.

Geräte-
Benennung

Stck
Hersteller /

Norm
Type

techn. Daten
Bestellnummer

zugehöriger
Decoder

zugehöriger
Satellite

gehört zu
Pumpe/
System

Bemerkungen

Tee1/1
1

Magnetventil 1 Perrot MVR 1"
1" - 12m³/h

VMF5 50305
1

1 Master Hy.Gr.: T+G
Hy.Sec.: T
Pumpename

8 Teilkreisversenkregner 4 Perrot LVZA 22WH  

Düse 4,5mm
500 m²

WW=14m
Q=1,6m³/h

P=5bar

1

1 Master

Tee 1/2
2

Magnetventil 1 Perrot MVR 1"
1" - 12m³/h

VMF5 50305
2

1 Master Hy.Gr.: T+G
Hy.Sec.: T
Pumpename

9 Vollkreisversenkregner 1 Perrot LVZE 22H

Düse 8mm
200 m²

WW=19m
Q=7,5m³/h

P=5bar

2

1 Master

FW 1/2
3

Magnetventil 1 Perrot MVR 2"
2" - 28m³/h

VMH5 50306
3

1 Master Hy.Gr.: FW
Hy.Sec.: FW
Pumpename

10 Vollkreisversenkregner 6 Perrot LVZR 22

Düse 12mm
5500 m²

WW=28m
Q=14m³/h

P=5bar

3

1 Master

FW 1/1
4

Magnetventil 1 Perrot MVR 2"
2" - 28m³/h

VMH5 50306
4

1 Master Hy.Gr.: FW
Hy.Sec.: FW
Pumpename

11 Vollkreisversenkregner 6 Perrot LVZR 22

Düse 12mm
5500 m²

WW=28m
Q=14m³/h

P=5bar

4

1 Master

G 1
5

Magnetventil 1 Perrot MVR 1½"
1½" - 20m³/h
VMI5 50307

5
1 Master Hy.Gr. T+G

Hy.Sec.: G
Pumpename

Bidirectional

12 Teilkreisversenkregner 4 Perrot LVZE 22WDH

Düse 6mm
600 m²

WW=18m
Q=5m³/h
P=5bar

5

1 Master

CR 16-10
6

Pumpe 1 Grundfos CR 16-10 16 m³/h 200
1 Master Bidirectional

CR 8-10
7

Pumpe 1 Grundfos CR 8-10 8 m³/h 201
1 Master

Betriebsmittelstückliste
Loch 1
Perrot-1234-4

 
 

5.2.4 Activation of Hydraulic Groups and Sectors 

During irrigation, the software tries to open as many valves as allowed by the pump 
capacity. This opening takes place according to an algorithm which considers only 
the flows of individual valves, not the arrangement of the irrigation piping. 
 
For the best calculated results, it is therefore important to divide the distribution 
piping network into hydraulic groups and sectors. Based on this information, the 
software can use the whole piping network and the full capacity of connected pumps 
in the optimum way. 
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Let us use this data in the Perrot Satellite software. 

5.3 Dividing the Area into Courses 

Irrigation of several different areas (such as sport grounds, parks or golf courses) can 
be controlled from a single PC. As mentioned in chapter 5.1, the total area to be 
irrigated can be divided into various sub-areas.  
 

 
 

 
You must have the "technician" privileges to create a new course. 

 

Hydraulic group 
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To create a new area (course), proceed as follows: 
 
In the Setup menu: 
 

1. Course Go to the Course submenu. 
 
 

 

2. Course name Click the Course name data field.  

 

3. 

 

 

Key in the name of the area (course). 

 
For ideas for structuring see chapter 5.1. Structuring a Project. 

 

4. New Click the New button. 
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Now we will enter all values and parameters for components of this area (course). 
  

5.4 Creating Satellites 

 
The valve controlling unit (VCU) transfers messages from the PC to 
connected actuators. At the same time, it also receives data from 
connected sensors and decoders. This means it works as a 
communication satellite between the controlling unit and the 
actuators/sensors. 
 
One link can include up to 9 satellites (VCUs). 
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To create a new satellite, proceed as follows: 
 
In the Setup menu: 
 

1. Satellites Go to the Satellites submenu. 
 
 

 

2. Satellite No. Click the Satellite no data field.  

 

3. 

 

 
Key in the required satellite number. 

 

4. Satellite 
identification Click the Satellite name data field. 

 

5. 

 

 

Key in the required satellite name (the place of the VCU installation, for 
example). 

 

6. New Click the New button. 

 
 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 59 / 180 

 

 

 

If there is no connection established between the PC and the VCU, the Inactive tick box 
must be ticked.   
This tick box must be ticked also before uploading new software to the VCU (update) – see 
chapter 3.5. 
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5.5 Creating Pump Data 

 

Each course must have a pump system assigned to it. 
Each pump system can contain up to 9 pumps controlled by 
Perrot Satellite. 

 
To create a new pump system, proceed as follows: 
 
In the Setup menu: 
 

1. Hydraulics Go to the Hydraulics submenu. 
 
 

 
 

2. Pump system 
name Click the Pumpsystem name data field.  

 

3. 

 

 
Key in the required name for your pump system (pumping station). 

 

4. New Click the New button. 
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5. Pumps Go to the Pumps screen by double-clicking the newly created pump 
system in the table or  

 

 
 

 
 

by clicking the Pumps tab.  

 
 

 
 
 

 

6. Pumps 
Please make sure you have selected the correct pump system. (Modify 
your  selection if needed.)  
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Creating a pump: 
 

7. Pump name Click the Pump name data field. 

 

8. 

 

 
Key in the required name of the pump. 

 

9. Pump flow 
(m³/h) Click the Pump flow data field.  

 

10. 

 

 
Key in the corresponding pump flow (capacity) in m³/h. 

 

11. New 
Click the New button. This will save the pump and its capacity. Repeat 
this procedure for all other pumps of the same pump system. 

 
 
 

 

If you want this pump system to be controlled autonomously (i.e. through 
pressure or frequency), you can key in only the total pumping capacity and do 
not have to create individual pumps. 
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12. Pump Go to the Pump screen by double-clicking the newly created pump in 
the table or  

 

 

 
 by clicking the Pump tab.  
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13. Pump 

Please make sure you have selected the correct pump system and 
correct pump (modify your  selection if needed) and specify parameters 
for your pump. 

 
 

 

14. Decoder 
number Click the Decoder-number  data field. 

 

15. 

 

 
Key in the number of the decoder which will switch the pump on and off. 

 

16. Satellite Choose the satellite to which the decoder will be connected. 

 

17. Bidirectional 
Inactive Tick the applicable pump characteristics. 

 

 

Bidirectional: 
If the connected decoder is capable of bidirectional operation. 
Inactive: 
If the pump is installed but currently not used. 
The software will then count with the pump capacity. 

 

18. Save Click the Save button. 
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19. Pump Repeat this procedure for all other pumps. 

 

 

If you fail to save your data by clicking the Save button, you will lose all 
the keyed-in data with the exception of the data set keyed-in last. 

 
 
 

5.6 Hydraulic Groups and Sectors 

 
The software always tries to open as many valves as allowed by the pump 
capacity during irrigation. 

 
If the valves are not assigned to any hydraulic group/sector, the software uses its 
own algorithm considering the flows of individual valves, but not the arrangement and 
dimensioning of the piping system. 
 
If two or more simultaneously operating valves are fed from the same piping branch, 
the overall irrigation efficiency may be negatively affected (pressure drop). In order to 
avoid this, please enter information in Perrot Satellite concerning which valves should 
be fed from which piping branch and the maximum allowed flow through different 
piping branches. 
 
By dividing the piping network into hydraulic groups and/or sectors, Perrot Satellite 
can use the whole distribution system in the optimum way and adjust the best 
pressure settings at different irrigation stations. 
 
Please calculate the maximum flow based on the piping network diameters and 
lengths. 
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Creating Hydraulic Groups: 
 
1. Groups Click the Groups tab. 

 

2. Pump system Choose the required pump system in the combo-box. 

 

3. Hydraulic 
group name Click the Hydraulic group name data field. 

 

4. 

 

 
Key in the required name for your hydraulic group. 

 

5. Max. group 
flow. Click the Group flow data field.  

 

6. 

 

 
Key in the maximum flow (hydraulic capacity) of the hydraulic group in 
m³/h. 

 

7. New To save the entered values, click the New button.  

 

 

Acceptable values: 0 - 999 m³/h 
The water consumption in any hydraulic group must not exceed the 
capacity (flow) of the feeding pump(s). 

 

 

8. repeat Repeat this procedure for all other hydraulic groups. 
 
 
 
 

Creating Hydraulic Sectors: 
 

 

Hydraulic sectors are actually "sub-groups" of the hydraulic groups.  
Each hydraulic sector is part of a hydraulic group.

 
9. Sectors Click the Sectors tab. 

 

10. Pump system Select the required pump system from the Pumpsystem combo-box.  
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11. Hydraulic 
group Select the required pump system from the Pumpsystem combo-box. 

 

12. Hydraulic 
sector name Click the Hydraulic sector name data field. 

 

13. 

 

 
Key in the required name of your hydraulic sector. 

 

14. Max. sector 
flow Click the Sector flow data field.  

 

15. 

 

 
Key in the maximum sector flow value in m³/h. 

 

16. New To save the entered values, click the New button.  

 

 

The flow in any hydraulic sector depends on the flow of its superior 
hydraulic group. It must not exceed the total capacity of the 
corresponding feeding pumps or the flow of the superior hydraulic group. 
Acceptable values: 0 - 999 m³/h 
Several sectors can be assigned to one hydraulic group. The actual 
assignment is done as part of entering the valve data. 

 

 

17. repeat Repeat this procedure for all other hydraulic sectors. 
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5.7 Selection Names 

Each valve can (but does not have to) have a selection name assigned to it to 
simplify valve searching and sorting. This name simplifies the creation of irrigation 
programs and/or searching for a particular valve in other menus. Assigning a 
selection name to a valve is specially important if a large number of valves is used 
within a system. 
 

 

The selection name should be a collective name describing several valves 
assigned to the selection. 
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Creating Selection Names:  
 
1. Course  Choose the required course in the Course combo-box. 

 

2. Selection 
name Click the Selection name data field. 

 

3. 

 

 
Key in the required name for your selection. 

 

4. New To save the entered name, click the New  button. 

 

5. 
 

Name The new selection name will be displayed in the Name table. 

 
 

 

 
New selection names can be added and existing names deleted at any time. 
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5.8 Valve Data 

 
In the Valves submenu, Valve tab, each valve is given a name and 
is assigned to a pump system, a satellite, a hydraulic group a sector 
and a decoder. In addition to these, the corresponding area to be 
covered by the valve and its flow must be specified for each valve. 

 

 

These values are to be determined by the installation technician during valve 
installation. The more accurate these data are, the better irrigation results can 
be achieved. 

 
Enter the valve values in the following way: 
 
In the Setup menu: 
 

1. Valve Go to the Valves > Valve menu. All valve values are entered and saved 
on this screen.

 
 

 

2. Course Choose the required course in the Course combo-box. 

 

 

3. Entering valve 
values Click the New button. 
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4. 

 

 
 

Tab            

 

Enter all the valve data starting with the decoder number. 
Use the Tab key to move to the next data field or click the required field 
with the mouse. Enter the Valve name, Area covered and Flow in the 
corresponding fields. 

 
 

 

 

Values and their ranges: 
 Flow:  0999 m³/h 
 Area covered: 099999 m² 

Possible abbreviations for valves: 
T  =  Tee 
B  =  Bunker 
D  =  Driving Range 
FW = Fairway 
G = Green 
P = Pitching Green 
R = Practice Area 
WW = Walkways 
 
Example: 
G 01 - 1 
 
   Sequential valve No. 
 Hole No. 
Green 
 
The software lists valves in alphabetical order. You can influence the 
order of their appearance by assigning certain systematic names to 
them. 
 
Names not recommended:   Recommended 
names: 
 G1      G01 
 G10      G02 
 G11        : 
 G12      G09 
   :      G10  
   :      G11 
 G18        : 
 G2        : 
 G3      G18 

 

 

 Use decoder numbers 1-230 for controlling the valves. 
 Use decoder numbers 230-244 for controlling the pumps. 
 The decoder number 245 has been reserved for reporting (feeding 

back) in case of a pump system error. 
 Decoder numbers 246-255 should not be used, but rather left as a 

reserve. 
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Then the valve has to be assigned to Selection (name), a Pump 
system, a Hydraulic group, a Hydraulic sector, a Destination course 
and to a Controlling satellite. The assignments are done in the 
corresponding combo-boxes. Use the mouse to choose/open a combo-
box and to select a value from its drop-down list. 

 

 

 Bidirectional 
Flow sensor 

Choose the additional characteristics by ticking the corresponding 
tickbox. 

 

 Save To save the entered values, click the Save button. 

 
 

 

 
 

 

Tick the Bidirectional tickbox if the installed decoder is of the 
bidirectional type. Such a decoder can send information back to the 
VCU. 
Tick the Flowsensor tickbox if the installed valve is a magnetic valve 
with a sensor and is controlled by a bidirectional decoder. 
This function provides feedback on the valve status and sends it to the 
VCU. It can only be used in combination with the Bidirectional function. 

 

5. repeat Repeat this procedure for all the remaining valves. 
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 Change 
Names and/or values of valves can be changed by going to the Valves 
submenu, clicking the Valves tab and double-clicking the line of the 
valve to modify. 

 

 
 

These changes will be accepted by the software only after you click the 
Save button. 
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5.9 Options (Pump Management) 

5.9.1 Switching Pumps On/Off by Program Start/End 

 
If more pumps are connected through a decoder, you can control them through the 
pump management options. You can:  
 

- switch them on/off 
- connect/disconnect them 

 

so that the pumps are used in the optimum way for the irrigation process. You can 
also manually control valves.  
 

 
You need to have Administrator rights to enter your data. 

 
Example – Operation with pump management 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The interval, the forerunning and the last running are delay times suitable for the 
irrigation technique. Their values are rather specific for each system and must be 
set up in such a way as to eliminate pressure surges (water hammering effect). 

 

Program Start 

Start Valve x 

 Interval  

Start Pump 1 

 Interval is the time between two pump starts or 
pump stops. 

 The valve only opens after all pumps are started 
and after their forerunning time (startup time) has 

 Lastrunning  

Stop Valve x 

 Interval  

Stop Pump 1 

Start Pump 2 

 The first pump only stops after the valves are 
closed and after the lastrunning time (run-down 
time) has expired. 

Stop Pump 2 

Program End 

 Forerunning 
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Standard values: 
 

Interval: 5 sec.  (small pump capacity    short interval) 
Forerunning: 20 sec. (many valves or long piping   long forerunning) 
Last running: 20 sec. (many valves or long piping  long last running) 

 
Enter the pump management values in the following way: 
 
In the Setup menu: 
 

1. Setup Options  

 Hydraulics 
  
Go to the Hydraulics > Options menu. 
 

 

 

 

2. Pump system  Choose the required (previously saved) pump system in the 
Pumpsystem combo-box. 

 

3. Flow/pressure 
measurement 

Are there flow/pressure measuring sensors installed in this pump 
system? 

 Satellite  Choose the required (previously saved) satellite to which the sensor is 
connected – from the combo-box. 

 

Automatic pump control: 
 

4. Forerunning: Click the Forerunning data field. 

 

5. 

 

 

Key in a forerunning (startup) time in seconds. 

 

You should monitor the pressure during irrigation to confirm that 
the entered values are correct. 

 
 

6. Lastrunning: Click the Lastrunning data field. 

 

7. 

 

 

Key in a lastrunning (run-down) time in seconds. 

 

You should monitor the pressure during irrigation to confirm that 
the entered values are correct. 
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8. Interval: 
Click the Interval data field.  

 

9. 

 

 

Key in an interval time in seconds. 

 

You should monitor the pressure during irrigation to confirm that 
the entered values are correct. 

 
 
 
 

Manual pump control (manual opening of valves): 
You can open valves manually from: 
 the Irrigation > Surveillance > Overview menu (see chapter 8.4) 
 the Service > Satellite > Decoder menu 
 transmitter  
 PDA 

 

10. Lastrunning: Click the Lastrunning data field. 

 

11. 

 

 

Key in a lastrunning (run-down) time in seconds. 

 

To shorten the waiting time, it is recommended to key in a 
shorter lastrunning time. 

 

12. Interval: Click the Interval data field. 

 

13. 

 

 

Key in a interval time in seconds. 

 

To shorten the waiting time, it is recommended to key in a 
shorter interval time. 

 

14. Save Click the Save button. 

 

5.9.2 Pump Control by Irrigation Programs 

 

 

 
In the case that all the pumps are controlled through a decoder, the pump control in 
Perrot Satellite has been modified in such a way that activated pumps supply exactly 
the required quantities of water (flow). 
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Pump Management in Irrigation Programs  
During irrigation, the required capacity of pumps is checked at intervals set under 
Setup > Options > Control (see chapter 5.7). 
Based on such a check, the optimum pump combination is calculated.  
This optimum combination is achieved through activating and deactivating different 
pumps. Activation has always priority to deactivation. Only one pump can be 
activated/deactivated during each interval. 
 
Pump Management in Valve Opening/Closing through the Overview Menu, a  
Transmitter or a PDA  
Pump activating and deactivating is done the same way as described earlier.  
 
Mean time used in calculating valve flow manual (i.e. Update interval for pump 
capacity)  
This field is important only if more pumps are controlled by a decoder simultaneously. 
In such a case, the pump control is taken over by Perrot Satellite. The program 
modifies the pump capacity according to the current demand. 
The interval in which individual pumps will be activated/deactivated can be specified 
in this field. 
The value entered in this field will apply to all irrigation programs. 
 
Acceptable values: 0 – 9999 sec. 
Standard value:  30 sec. 
 

 

If you set the pump capacity update interval to "0" seconds, it turns the 
pump management off and all pumps will run simultaneously during 
the selected irrigation program. 

 
Mean time used in calculating valve flow automatic (special function) 
The optimum pump sequence is determined during the operation of an irrigation 
program, based on the currently calculated flow through different valves. This helps 
to reduce the effects of flow fluctuations during the irrigation process. The optimum 
pump sequence is always determined thanks to the built-in calculation of mean 
values. 
This field serves for entering the interval stating how often the mean value should be 
calculated during the irrigation process. It depends on the current flow through 
valves. The valve flow in the last 30 seconds determines the calculation of the pump 
sequence and it is based on the 30 sec. mean value. 
The value entered in this field sets the calculation interval. 
 
Standard:   30 sec.



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 78 / 180 

 

6 Irrigation Programs 

The Perrot Satellite software makes it possible to create optimum irrigation programs. 
These irrigation programs are tested by their internal simulation. 
The simulation then serves for calculating the optimum irrigation process by the 
integrated Pump-Flow-Manager  with respect to the entered basic data.  
Then the irrigation process is calculated in such a way as to use the available pump 
capacity most efficiently, not exceeding 100%. This will achieve the shortest possible 
irrigation time and the optimum use of the system resources (pumps, piping, etc.). 

6.1 Description of Different Program Types 

6.1.1 Valves (individual valves) 

To create an irrigation program, you have to set an irrigation time or a precipitation 
density under the Setup > Valves menu. Valves to be activated by this particular 
program can be selected through the selection function.  
This makes it possible to create individual programs for the widest range of irrigation 
needs for various areas located exposed to different conditions. Yet these values 
must be entered for each valve separately, which may become rather time 
consuming where there are large numbers of valves to be programmed. 
Perrot Satellite then determines the irrigation procedure (valve activation order) by 
means of a simulation. The user can change the order of valve activation if needed. 
 

6.1.2 Valve Collections 

If you want to create programs using valve collections, you have to start by creating 
these collections and then specifying which particular valves you want to include in a 
particular collection.  
It might be beneficial to include all valves irrigating greens or fairways in one 
collection. 
This way, you can then set different precipitation densities for different valve 
collections and then modify these values to optimise the irrigation efficiency. 
This method of valve collecting has the advantage of a low number of values to 
enter, which makes programming and data monitoring very easy and saves 
operator's time. Only the initial creation of collections is rather time consuming. 
Perrot Satellite then determines the irrigation procedure (valve activation order) by 
means of a simulation. The user can change the order of valve activation if needed. 
 

6.1.3 Manual Program 

This type of program is not controlled by the Flow-Manager but rather by the operator 
who determines which valves should open together and in which order. The operator 
also determines, which pump(s) should be activated. The program then performs its 
tasks step-by-step where each step can have up to 8 valves assigned to it by the 
operator. Individual valves open shortly one after another within one step. The 
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operator can, however, program a delay between individual valve openings and 
closings. 
This type of programming allow the operator to choose a completely arbitrary order of 
valve/pump activation and/or their combinations – something that is not possible in 
the other two program types, which have the order and combination of valves and 
pumps determined by the software Flow-Manager. As this type of programming is 
very time consuming, it is recommended to use it only for the above cases or 
situations. 
 

 

Should there be changes made in the irrigation program settings or data 
which prolong or shorten the program running time, the Perrot Satellite 
software will process the new values automatically. The only thing you 
must check and make sure of is that the times of individual irrigation 
programs (if prolonged) do not overlap in the irrigation calendar. 

 

6.2 Creating Irrigation programs 

 
Main programming steps: 
 

 
Choose program types  

 
Choose the program type to best suite your needs. 

  
Choose course, pumps, 

valves and possibly 
valve collections 

Choose suitable pumps, valves or valve collections for 
the given course. 

  

Enter irrigation data 

 
Enter the required irrigation values in the corresponding 
fields or table. 
 
 

  

Program simulation 

Perform the program simulation. The program verifies 
itself and prepares for execution during the simulation. 
The program cannot be used without this test. The 
simulation displays the step-by-step program process as 
calculated by the Flow-Manager. This is how the 
program will operate. 

  

Print 
You can print the program values. This will give you a 
survey of the program, available at any moment. 

  

Start program through 
irrigation calendar 

Start the selected program through the irrigation 
calendar. All data will be transferred from PC to VCU 
online. The PC will send orders to the VCU when 
different valves should be activated. 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 80 / 180 

  

6.2.1 Programming Individual Valves 
 

This is where all valves recorded in the programming table and 
marked as active can be opened. The software considers the 
pump data, entered precipitation density and program running 
time to achieve the optimum pump capacity.  
The order, in which valves open, is determined by the software, 
or alternatively it can be defined manually in a special 
programming table column. 

 

 
 

6.2.2 Programming Valve Collections 

 
If you do not want to program each valve separately, you can 
combine selected valves in the given course into a valve 
collection. 
 

The "Valve Collection" program type then opens all valves 
included in the particular collection, while respecting the pump 
values. The order in which valves open is determined by the 
Flow-Manager. This order does not depend on the collection 
assignment. 

 

 

 

Advantage: This program type offers an easy to survey table. Even large numbers of 
valves can be controlled by means of one collection.  
Disadvantage: This program type cannot control individual valves directly (unless one 
valve is defined as a whole collection). 

 

6.2.3 Operator-Controlled Program Operation  

Prepared for special types of programs only (see chapter 6.1.3). 
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6.3 "Valve" Irrigation Program  

 

 
You need to have the technician rights to create new programs. 

 
To create a new irrigation program, proceed as follows: 
 
In the main menu: 
 

1. Programs Edit  

 Valves 
  

Go to the Valves submenu. 
 

 

The program table: 
 

 
Valve name.:  This column displays names of all valves saved for this course. 
   Each valve is displayed in a separate row. 
 

Sequence:  Enter the order of opening.  
Values: 0 – total No. of valves 
If the standard value of 0 is left in the field, the Flow-Manager sets the 
sequence automatically. 

 You can change the order of opening by specifying sequential numbers from 1 
to nn for individual valves (where nn is the total number of valves). The valves 
with the lowest sequence number opens as the first one and so on. 

 

The sequence numbers must be filled-in for all valves! 
All valves must have either 0 or 1-nn value specified. 

 

Density:  Enter the required precipitation density here. 
Values: 0  - 999 mm 
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Based on your entered values and on the basic values, the Flow-Manager 
calculates how long the valve must be open and the water consumption in  
m³/h and write these values automatically in the corresponding fields. 
 

Time:   Enter the required duration the valve should be open: 0 - 479 minutes 
   Once you enter your value, the precipitation density is calculated 
automatically. 
 

Consumption:  This field displays the calculated water consumption (m³/h). 
 

Use   Here you can activate or deactivate individual valves. 

    = active  = deactivated  
 
Valves with the time or consumption value specified as 0 do not have to be deactivated as they are 
skipped in the irrigation program anyway. 
 
 

2. Course  
Select one of the saved courses – the one for which you want to create 
an irrigation program. Valves created for this course will display in the 
table.  

 

There are 2 methods to create a new irrigation program: 
 

6.3.1 Creating a New Irrigation Program (from scratch) 
 

Procedure: 
 

1. Programs: 
Click the data-entering field. If the field already contains a name, 
highlight it completely with the mouse. 

 

2. 

 

 

Key in a new program name. 

 

Give your program a unique name up to 8 characters (letters 
or digits) long. Choose a name, which describes the purpose or 
use of the program. 

 

3. 
 

New 
Click the New button. The system accepts the new program name and 
deletes (zeroes) all values in it. 

 

4. Valves / Edit Open the pull-down menu of the Select combo-box by clicking it.  

 

5. Valves / Edit Choose valves for which you want to create the new program. 

 
 
 

 

Warning:  
You can tick only one tickbox at a time. Confirm your selection by clicking 
the Select button. Then the pull-down menu can be reopened. 

 
 
 

 

Note: 
Valves without a (sorting) name will be displayed automatically. 
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6. Valves / Edit   
 

 

 

 

7. Valves / Edit 
Additional valve collections can be added to an existing 
program or existing collections deleted from it. All valves are 
displayed in one list. Use the scrollbar in long lists.  

 

 

 
 
 
 

Modifying Table (Entering Values and Activating Valves) 
 
 

 Density column  

2a. 
 

Enter density 
Click the field at the intersection of the Density column and the required 
valve row. 

 

or 
 

 Time column  

2b. 
 

Enter time 
Click the field at the intersection of the Time column and the required 
valve row. 
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3. 

 

 

Key in your value. 

 
The density value is in [mm] 
The time value is in [min] 

 

 Sequence column  

4. 
 

Enter sequence 
Click the field at the intersection of the Sequence column and the 
required valve row. 

 

5. 

 

 

Key in your value. 

 

Make sure that all valve collections have either 0 or 1-nn as 
their value.  
Entering the opening order (sequence)  
Value: 0 – total No. of valves 
If the standard value of 0 is left in the field, the Flow-Manager 
sets the sequence automatically. 
You can change the order of opening by specifying sequential 
numbers from 1 to nn for individual valves (where nn is the total 
number of valves). The valve with the lowest sequence number 
opens first and so on. 
The sequence numbers must be filled in for all the valves! Make 
sure that all the valves have either 0 or 1-nn value specified. 

 
 
 
 

6. 
 

Test >> Click the Test >> button. This will start the simulation of your program.  

 

The program cannot be executed without this simulation!  
The program is verified for correctness by the test and prepared 
for running. It is not possible to start the program without this 
test.  
The simulation test performs the program exactly according to 
the Flow-Manager's calculations. 
The program will run the same way during real irrigation. 

 

 

 

Print 
Click the Print button. A print preview window opens displaying all the 
program data. You can print this report if there is a printer connected to 
your PC. 
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6.3.2 Making a Copy of an Existing Program (Saving it under a Different Name) 
  

Procedure: 

1. Program  Select the program you want to copy in this combo-box. 
The table displays all the values saved for this program. 

 

2. 
Program: 

 
Key in a new program name. 

  

 

Give your program a unique name up to 8 characters (letters 
or digits) long. 

 

3. 
 

Copy 
Click the Copy button. All the values are preserved in the table, but 
under the new name now. 

 

4. Modify data 
Modify necessary values as described in the previous section (6.3.1 
Creating a New Irrigation Program). 

 

5. 
 

Test >> Click the Test >> button. This will start the simulation of your program. 

 
The program cannot be executed without this test! 

 
 
 
 
 
 

6.4 "Valve Collection" Irrigation Program  

6.4.1 Creating Valve Collection Budgets 

To create an irrigation program using a valve collection budget, proceed as follows: 
Create the required valve collection names in the Setup > Course > Valve 
collections menu, 

 for example:  FW01 (for all sprinklers on Fairway 1) 
    or 

    G11   (for all sprinklers on Green 11) 
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Assign individual valves to valve collections in the Setup > Course > Valve 
collection menu: 
 Choose one of the already created valve collection names. 
 Choose the valves you want to include in the selected valve collection by 

clicking them in the left (white) field and by clicking the Add >> button. 
 The Budget % field will show the percentage of the irrigation time assigned to 

this valve collection compared to the total irrigation time. 
 
All the budget values can be modified at any time. The operator can gradually "tune 
the times in" to achieve the optimum results for all the valve collections and the 
irrigated areas. The modified values are automatically transferred into all the irrigation 
programs created in the Programs > Valve collections > Edit menu. 
 

 

 

 

6.4.2 Creating a "Valve Collection" Irrigation Program  

 
You need to have technician rights to create a new irrigation program. 

 
To create a new irrigation program, proceed as follows: 
 
In the main menu: 
 

1. Programs Edit  

 Valve collections 
  

Go to the Valve collections submenu. 
 

 

2. Course  
Choose one of the previously saved courses for which you want to create an 
irrigation program. All valve collections created for the chosen course will 
display in the table. 
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The programming table: 
 

 

 
Valve collection name: Names of all valve collections created for this course. 

  

These valve collections must be previously created and defined in the 
Setup > Course > Valve collection menu (see chapter 6.4.1).  

  

Sequence:  To define the sequential order. 
Values: 0 - max. number of valve collections 
If the standard value of 0 is left in the field, the Flow-Manager sets the 
sequence automatically. 

 You can change the order of opening by specifying sequential numbers from 1 
to nn for individual collections (where nn is the total number of valve 
collections). The collection with the lowest sequence number opens as the 
first one. 

 

The sequence numbers must be filled-in for all valve collections! 
All collections must have either 0 or 1-nn value specified. 

 

Density:  Enter the required precipitation density here. 
Values: 0  - 999 mm 
Based on your entered values and on the basic values, the Flow-Manager 
calculates how long the valves must be open and the water consumption in  
m³/h and write these values automatically in the corresponding fields. 
 

Consumption:  This field displays the calculated water consumption (m³/h). 
 

Use   Here you can activate or deactivate individual valves. 

    = active  = deactivated  
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There are 2 methods to create a new irrigation program: 
 

6.4.3 Creating a New Irrigation Program (from scratch) 
 

Procedure: 
 

1. Programs: 
Click the data-entering field. If the field already contains a name, 
highlight it completely with the mouse. 

 

2. 

 

 

Key in a new program name. 

 

Give your program a unique name up to 8 characters (letters 
or digits) long. Choose a name, which describes the purpose or 
use of the program. 

 

3. 
 

New 
Click the New button. The system accepts the new program name and 
deletes (zeroes) all values in it. 

 

4. Valves / Edit Open the pull-down menu of the Select combo-box by clicking it.  

 

5. Valves / Edit Choose valves for which you want to create the new program. 

 
 
 
 

 
Modifying Table (Entering Values and Activating Valves) 
 

 Density column  

1.  

Enter density 
Click the field at the intersection of the Density column and the required 
valve row. 

 

2. 
 

 

Key in your value. 

 
The density value is in [mm] 
(Time cannot be entered for valve collections.) 

 

  Sequence column  

3.  

Enter sequence 
Click the field at the intersection of the Sequence column and the 
required valve row. 

 

4. 

 

 

Key in your value. 

 

Make sure that all the valves have either 0 or 1-nn value 
specified. 
If a sequence number higher than 0 is specified, the valves 
in the collection with the lowest sequence number open as 
the first ones.

 

5. 
 

Test >> Click the Test >> button. This will start the simulation of your program. 

 
The program cannot be executed without this simulation! 

 

 

 

Print 
Click the Print button. A print preview window opens displaying all the 
program data. You can print this report if there is a printer connected to 
your PC. 
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6.4.4 Making a Copy of an Existing Program (Saving it under a Different Name) 
  
 

Procedure: 

1. Programs  Select the program you want to copy in this combo-box. 
The table displays all the values saved for this program. 

 

2. Program: 
 

Key in a new program name. 

 

Give your program a unique name up to 8 characters (letters 
or digits) long. 

 

3. 
 

Copy 
Click the Copy button. All the values are preserved in the table, but 
under the new name now. 

 

4. Modify data 
Modify necessary values as described in the previous section (6.3.1 
Creating a New Irrigation Program). 

 

5. 
 

Test >> Click the Test >> button. This will start the simulation of your program. 

 
The program cannot be executed without this test! 
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6.5 "Manual" Irrigation Program  

 

6.5.1 Procedure 

Main programming steps: 
 
  

Choose pump(s) 
 

 

   
 
 
 

Step x: 
Choose valves 

Choose valves for each step. 

   
 

Step x: 
Choose time 

 
Choose duration time for each step. 
 

   
 
 
 

Program simulation Perform program simulation. 

 
 
 

 

Warning! The pump capacity must not be exceeded!  
Incorrect data might result in overloading the pumps! 

 

 

These "manual" programs should be programmed by sufficiently experienced experts 
only. 

 

 

It is recommended to record the planned program step-by-step on a sheet of paper. Only 
after you check all its steps and compare them with the pump capacity can you start 
entering its individual steps in the software. 

 
 

 
You need to have technician rights to create new programs. 
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To create a new irrigation program, proceed as follows: 
 
In the main menu: 
 

1. Programs Edit  

 Manual 
  

Go to the Programs > Manual submenu. 
 

 

 

2. Course  Select one of the saved courses – the one for which you want to create 
an irrigation program.  

 

There are 2 methods to create a new irrigation program: 
 

6.5.2 Creating a New Irrigation Program (from scratch) 
 

Procedure: 

1. Programs: 
Click the data-entering field. If the field already contains a name, 
highlight it completely with the mouse. 

 

2. 

 

 

Key in a new program name. 

 

Give your program a unique name up to 8 characters (letters 
or digits) long. Choose a name, which describes the purpose or 
use of the program. 

 

3. 
 

New 
Click the New button. The system accepts the new program name and 
deletes (zeroes) all values in it. 

 

 Select pump(s)  

 Enter the step No.   
 Choose valve(s)  
 Enter running time  

 

 

4. Pumpsystem  Choose the required pump system to which the activated pump is 
connected. 

 

5. Pump  Choose the pump to activate. 
 

6. Add >> Click the Add >> button.  

 
 

7. 
Additional 
pumps? 

Pump  You can add additional pumps to the right-side list-
box by 

Add >> 
 choosing another pump and transferring it to the box 

by clicking the Add >> button. 
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Removing Pumps from List-Box 
 

 Choose pump Choose the required pump in the list-box.
 

 

<< Remove 

Remove the highlighted pump from the list-box by clicking the << 
Remove button. 

 

This, however, changes the overall pump capacity. Check the 
available pump capacity listed on the screen for each step. 

 

The chosen pumps apply to the whole program. They cannot be 
changed for individual steps. 

 

 Select pump(s)  
 Enter the step No.  

 Choose valve(s)  
 Enter running time  

 

 

8. New step 
As a new program is being compiled, the Step No. field will be filled with 
"0". Clicking the New step button will insert the next (higher) number in 
the Step No. field. 

New step Delete step 

 
Step 
no.  Choose step No. Step No.  Choose step No. 

 
New 
step  

This creates a new 
step. The new step 
will be numbered 
as the current step 
+1. 

Delete 
step  

This deletes the 
current step. The 
next step will be 
numbered as the 
current step –1. 

 
 Enter the step No.  
 Choose valve(s)  

 Enter running time  
 

9. Valve list  Choose the required valve in the left-hand list-box. 
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10. 
 

Add >> 
Click the Add >> button. The valve will be displayed in the Valve name 
table in the right. 

 

11. 
Additional 
valves? 

Valve list  
You can add additional valves to the right-side list-
box by 

Add >> 
 choosing another valve and transferring it to the box 

by clicking the Add >> button. 
 
 Enter the step No.   
 Choose valve(s)  
 Enter running time  

 
 

12. Time (min) Click the Time (min) data field.  

 

13. 

 

 
 

Key in the required running time (length) for the displayed step. 

 

 

Pay attention to the information that appears on the screen for the 
displayed step! 

 

 
Program consumption(m³) 

This displays the water consumption for 
the current step.  

 
Program duration (hh:min) 

This displays the running time (duration) 
of the valves chosen for the current step. 

 
Pump efficiency (%) 

This displays the needed pump capacity 
for the valves chosen for the current 
step. 

 

 

Warning! You must check the available pump capacity in this type of 
program! Incorrect data might exceed the pump capacity resulting in 
the pump overloading!  
(The pump capacity must not exceed 100%!)

 
Individual steps are to be compiled as follows: 
 
1 Enter new step No. See point No. 8 
2 Choose valve(s) See point Nos. 9 - 11 
3 Enter running time See point Nos. 12 - 13 

 
 
 

14. 
 

Test >> Click the Test >> button. This will start the simulation of your program. 

 
The program cannot be executed without this test! 
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Print 
Click the Print button. A print preview window opens displaying all the 
program data. You can print this report if there is a printer connected to 
your PC. 

 

  

 

6.5.3 Making a Copy of an Existing Program (Saving it under a Different Name) 
 

Procedure: 

1. Programs  Select the program you want to copy in this combo-box. 
The table displays all the values saved for this program. 

 

2. 
Program: 

 
Key in a new program name. 

  

 

Give your program a unique name up to 8 characters (letters 
or digits) long. 

 

3. 
 

Copy 
Click the Copy button. All the values are preserved in the table, but 
under the new name now. 

 

4. Modify data 
Modify necessary values as described in the previous section (6.3.1 
Creating a New Irrigation Program). 

 

5. 
 

Test >> Click the Test >> button. This will start the simulation of your program. 

 
The program cannot be executed without this test! 

 

 

 

Print 
Click the Print button. A print preview window opens displaying all the 
program data. You can print this report if there is a printer connected to 
your PC. 
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6.6 Creating Irrigation Schedule 

 

This schedule provides the overall control of the irrigation procedure. You 
can program it to specify which irrigation program should start 
automatically on which day of which week at which course and at what 
time. 

 
The automatic irrigation control (schedule) can be programmed up to two weeks in 
advance. The schedule then repeats automatically.  
You can start an unlimited number of programs each day. 
 
To create a new schedule, proceed as follows: 
 
In the main menu: 

1. Irrigation Edit   

 Schedule 
  

Go to the Irrigation > Schedule > Edit menu. 
 

 
 

 

2. Schedule 
name Click the Schedule name data field.  

 

3. 

 

 

Key in a suitable name and save it by clicking the New button. 

 

Choose a unique name, which describes the purpose or use of 
the schedule. 

 

4. Beregnungs-
plan 

Click the New item button.  
The system offers irrigation programs to choose from.  
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5. Schedule 
You can click individual fields in the table (Course name, Program 
name, Day, Corr.% or Start) and modify their values so that the selected 
program starts on the required day and at the required time. 

 

6. Schedule 
To call up additional programs, click the New item button again and 
modify the values as described in the previous step. 

 

 

There must be a pause of at least one minute between finishing a program and starting 
another. 
Should program times overlap, the line will change its colour into red. You can remove such 
an overlap by changing the program start time. 
Schedules that contain overlaps will not be executed! 

 

 
Irrigation programs can run simultaneously at different courses. 

 

 

Changes made in start times of irrigation programs may prolong the overall 
time of the schedule and it may start overlapping with another schedule! 

 

 

You can create an unlimited number of schedules with different irrigation 
frequency and/or intensity to suit different climatic and weather conditions 
(summer, autumn, sunny, clouded). 
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Description of editable data fields: 

Schedule name  
This is where you can create new schedules. It is recommended to use 
meaningful names that describe their purposes, such as "Spring" or 
"Summer", for example. 

Course name If the irrigated area consists of several courses, choose the course in which 
you want to start the irrigation program. 

Program name The combo-box displays all tested programs assigned to this course. 

Day The combo-box displays all days of the week to choose from. 

Corr.%  Here you can prolong or shorten the running time by a percentage (time with 
valves opened). Standard: 100%, min 10%, max. 300%. 

Start  Here you can enter the required start time. The time is to be entered it in the 
hh:mm format. 

 
Description of non-editable (display-only) data fields 

Current 
This field displays the current day of the week and information whether the 
current week is even or odd.  

Plan for This field displays information whether the currently displayed week is even 
or odd.  

Finish This field displays time at which the irrigation program will finish. 

Time This field displays the program running time (duration), taking into account 
the Corr.% factor for the given program. 

Cons. This field displays the calculated water consumption of the given program, 
taking into account its Corr.% factor. 

 
Description of buttons 
New This button saves new schedules. 

Delete This button deletes both the schedule name and its content. 

Print This button opens the print preview of the given schedule. 

New item This button adds a new program in the current schedule. 

Delete item This button deletes the selected program from the current schedule. 

Delete all This button deletes all programs from the current schedule. The schedule is 
not deleted and can be redefined (= filled with programs). 

Even/Odd weeks The screen always displays only one week. These buttons toggle between 
even and odd weeks.  
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6.7 Automatic Irrigation Procedure  

You can set your irritation to run automatically in the Irrigation > Schedule > 
Control menu.  

 
 
Procedure: 

1. Active 
schedule  Choose the required schedule from the pull-down menu which displays all 

available schedules. 
 

2. Run 

Clicking the Run button activates the following steps: 
 The Awaiting program field displays the program which will start as 

the next one. It is always the program with the nearest start time. 
 The Irrigation status changes from "Stopped" to "Running". 

Once a schedule is started, it displays its programs in the Active programs 
list box. 

 

3. Pause 

Clicking the Pause button interrupts the running program. 
 The Irrigation status changes from "Running" to "Paused".  
 Clicking the Restart button resumes the program operation from the 

point at which it was paused. 
 

4. Stop 
Clicking the Stop button:  

 The Irrigation status changes from "Running" to "Stopped".   
 The irrigation process stops, no further programs will be executed. 
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6.8 Irrigation Status – Terminology Explanation 

 
 

The Irrigation status line is always displayed on the screen regardless of the 
currently displayed menu. This way the user can check the current irrigation status at 
any moment.  
The yellow LED on the VCU is another indicator of the irrigation status. 

 
Following Table presents each possible status: 

 

Irrigation status Yellow LED on VCU Situation Note 

Stopped 
short on, long off 
blinking 

No irrigation program will be 
automatically started.  

Off mode 

Running 
long on, short off 
blinking 

Irrigation programs will start 
automatically. The program will wait 
for the next start time. 

Stand-by mode 

Running on An irrigation program is running. Running mode 

Paused 
long on, short off 
blinking 

A running program has been 
paused (interrupted). 

Stand-by mode 
Program execution can be 
resumed by clicking the 
Restart button 

Weather 
long on, short off 
blinking 

During the "Running" irrigation 
status, one of the activated sensors 
had its limit value exceeded 
(specified under the Irrigation > 
Parameters menu. Irrigation 
cannot be started nor can a running 
program paused in this state.  

Standby mode 
Irrigation can only resume 
after resetting the external 
sensor (automatically or by 
the user). 

Error off (the red LED is on) 
The software has detected an 
error, which is described under the 
Service > Error handling menu.  

Irrigation can only resume 
after removing the error and 
resetting the program. 
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6.9 Manual Start of Irrigation Program  

You can manually start any irrigation program manually, regardless of the current 
time.  
 

 

Remember the following points:  
 Manual start can only be done in the "Stopped" irrigation status.  
 The irrigation program changes its status into "Running" after the 

manual start. 
 After the program execution, the irrigation status turns back to 

"Stopped". 
 If a program is started manually, it cannot switch into automatic 

control mode and vice versa. 
 

 
 

1. Course  Click the Course combo-box and choose the course for which you want 
manually start an irrigation program. 

 

2. Program  Click the Program combo-box and choose the required program. 
 

3. Correction (%) Change the correcting factor if needed. 
 

4. Run Click the Run button.  
 

5. Program The irrigation program starts immediately.  
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Start time and finish time of the manually started program display under the 
Irrigation > Schedule > Control menu and under the Irrigation > Schedule > Edit 
menu: 

 
 
The Active schedule combo-box gives information that the irrigation program has 
been started manually (“Single program” displayed).  
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7 Sensors and Other External Devices 

You can affect the irrigation process in Perrot Satellite by means of various external 
devices such as rain sensors, flow/pressure sensors or wind sensors. 

7.1 System Data and External Devices 

Configuration menu for external devices: 
 

 

 
S3 Closer:  This input is used for a rain sensor (digital input) 
 
S4 Opener:  This input is used for a rain sensor (digital input) 
 
S5 Q/l:   This input is used for a flow sensor (analog input, range 0-20 mA) 
    
S6 P/l:   This input is used for a pressure sensor (analog input, range 0-20 mA) 
 
S7 V/I: This input is used for a wind gauge (anemometer)  

(analog input, range 0-20 mA)  
 

S8 XY/l:  This input can be used for another sensor (analog input, range 0-20 mA) 
 
S9 Frequency 1: This input can be used for a sensor with a frequency output 
   (frequency range must be greater than 5-10 Hz; input range: 0-1000 Hz) 
 
S10 Frequency 2: This input can be used for a sensor with a frequency output 
   (frequency range must be greater than 5-10 Hz; input range: 0-1000 Hz) 
 
Application:  Key in a suitable name for your external device in these fields, 
   (e.g. what will be metered). The name can be up to 8 characters long. 
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Working with an External Sensor 
 

 

Current (mA) values from the connected sensors are metered at 
VCU's inputs S5 to S8 and the readings sent to the software. Inputs 
S9 and S10 meter frequencies and also send the values to the 
software. The software recalculates these values into pressure or 
speed by means of the Scale and Offset parameters and prints the 
final values in a report or displays them on the screen of the 
Irrigation > Parameters menu. 

  

7.1.1 Scale 
 

As satellites (VCUs) can read values only in mA or Hz, the scale recalculates the 
readings to be presented as pressure/speed values. 
 
 
 Calculation: 1 Hz = ?m/s scale value × metered value in Hz = displayed value in m/s 
   1 mA = ?bar scale value × metered value in mA = displayed value in bar 
   1 mA = ?m/s scale value × metered value in mA = displayed value in m/s 
 
 
 Example 1: Wind gauge sends 4.4 pulses per second (4.4Hz) in one revolution 

One revolution corresponds with a wind speed of 1 m/s. 
   ? m/s = 1Hz:  1m/s: 4.4 Hz = 0.22 m/s per 1 Hz  Scale = 0.22 
    

Example 2: Pressure sensor sends a linear signal of 4-20 mA corresponding with the pressure 
of 0-25 bar. 

   ? bar = 1mA:  25 bar : (20-4) mA = 1.56 bar per 1mA  Scale = 1.56 
 
 

 

The sensor sends a value of 4 mA at the pressure of 0 bar, this 
means that the software would show 4 × 1.56 bar = 6.24 bar. For this 
reason the displayed value must be set off by means of the Offset 
parameter. 
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7.1.2 Offset 
 

Offset is a correcting value applied to the Scale value of analog or frequency inputs. 
This correcting value is added to or subtracted from the measured and Scale-
recalculated value. This means that the calculation of the value to be displayed uses 
the Scale value corrected by the offset value. 
Range: -999.9 – +999.9 
 

Example: Pressure sensor sends a linear signal of 4-20 mA corresponding with the pressure 
of 0-25 bar. Scale = 1.56 (see example 2 above). 

   Calculation:   4 mA × 1.56 bar/mA = 6.24 bar (displayed value) 
   Offset value: displayed value – Offset value = 0 bar  Offset value = -6.24 
 

 

The scale-recalculated metered value is corrected by the offset value 
(with the minus sign). This results in the true displayed value. 

 

7.2 Connecting a Rain Sensor 

 
The rain sensor operates as a switch that closes in case of rain. 
It is directly connected to a satellite (VCU). If the rain sensor 
reports rain, Perrot Satellite pauses the irrigation process. Once 
the rain stops and the rain sensor pre-set delay expires, the 
irrigation program resumes its operation from the point at which 
it was paused. 

 

 

 

Please follow producer's installation and operation instructions for 
your rain sensor. Do not activate any devices that have not been 
installed! 

 

 
Do not install your rain sensor inside the irrigated area! 

 

 

A rain sensor DOES NOT affect manually opened valves or manually 
started programs! 

 
Depending on its type, a rain sensor can be connected to the VCU's digital input as a 
closer or an opener. 
 
To connect a rain sensor as a closer, use  Terminals 11 and 12 
To connect a rain sensor as an opener, use  Terminals 13 and 14 
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Wiring diagram 

 

 
 

 
For an overall VCU wiring diagram see chapter 2.4. 

 

 

Please make sure that a Weather parameter timeout has been defined in 
the Setup > Options > Control menu. 

 

 

 

If the rain sensor does not open within the defined time, the currently running 
irrigation program pauses.  
Should the resumed irrigation program overlap with another planned 
program, the paused (interrupted) program will be terminated. 
Acceptable values:     0 – 999 min 
Standard value:                  60 min 

 

 

Recommended rain sensor set: 
 Manufacturer: Hunter Mini-Click rain sensor 
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To register a rain sensor, proceed as follows: 
 
In the main menu: 
 

1. Setup Settings  

 Satellites 
  

Go to the Setup > Satellites > Settings menu. 
 

 

 

2. Satellite  Choose one of the existing satellites. 

 

 

Check which type of the rain sensor you have installed (opener or 
closer). 

 

3. Opener or 
closer 

 
Click the Closer or Opener data field.  

, 

4. 

 

 

Key in a suitable name. 

 

Use a unique name. 
The name can be up to 8 characters long (letters or digits). 

 

5. Save Click the Save button. 
 

 
Once you have your rain sensor installed and all its installation values entered, you 
have to activate it. Only then it will be able to pause irrigation as needed. 
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To activate a rain sensor, proceed as follows: 
    
1. Irrigation Edit  

 

Parameters 

 

2. Satellite  Choose the satellite to which your rain sensor has been connected in 
the Satellite settings combo-box. 

 

3. Closer or 
opener 

 
Tick the Closer or Opener tickbox. 

 

3. Closer or 
opener 

 
Click the Update satellite settings button. 

 

 

If you have proceeded correctly, the (Application) column shows the name 
of the registered sensor. 
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7.3 Connecting Sensors 

7.3.1 Connecting a Flow Sensor 

 
The flow sensor measures the current flow-through value and 
displays it on the screen of the Irrigation > Parameters > Edit 
menu. 
The flow value measured at a given moment is documented on 
the screen of the Reports > Irrigation > Irrigation programs 
menu. 
This flow value serves for comparing with the theoretical values 
defined and their optimising. It also works as a safety device: 
should the max./min. limit flow be exceeded/not achieved, the 
pump station switches off. This could happen in the event of a 
leaking pipe or a pump running against a closed shut-off valve. 

 

 

 

Please follow producer's installation and operation instructions for 
sensors. Do not activate any devices that have not been installed! 

 
Wiring diagram 
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Connecting Example: 
 
Flow meter type: Kobolt turbine-gear flow meter with integrated converter 

Type TUR 2… . 
Option A, output 0-20 mA 

 
Metering: The nominal metering range (e.g. 2-80 m³/h) is linearly detected and 

converted into a 0-20 mA signal. This means that 1 mA = 4 m³/h. 
 
Scale:    The scale value is 4.0. 
 

 

The voltage drops from 24 V to approx. 17 V in case of the maximum flow 
(here 80 m³/h). Voltage between the grounding and the pin No. 20 increases 
by the same value. 

 

 

Alternatively you can check the correct functioning of the metering 
converter by checking the voltage between pins 19 and 20 on the VCU. 

 
To register flow sensor values in the software, proceed as follows: 
 
In the main menu: 
 

1. Setup Settings  

 Satellites 
  

Go to the Setup > Satellites > Settings menu. 
 

 

 
 

2. Satellite  Choose the satellite to which the flow meter is connected. 
 

3. Scale 

 
Click the Scale field in the S5 Q/l Flow line.  
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4. 

 

 

Key in the calculated scale value. 

Calculate the scale value as described above.  

 

5. Save Click the Save button. 
 

 

 

Print 
Click the Print button to print all the entered parameters by means of a 
connected printer. 

 
 

 

7.3.2 Connecting a Pressure Sensor 

 
The flow sensor measures the current pressure value and displays it on the 
screen of the Irrigation > Parameters > Edit menu. 
The pressure value measured at a given moment is documented on the 
screen of the Reports > Irrigation > Irrigation programs menu. 
With the help of these values, you can check that no unacceptable pressure 
peaks occur during irrigation start up or during opening/closing of valves. In 
addition to this, you can check that the overall pressure in the system is not 
too low/high and if so, you can decide whether to increase/decrease the flow 
to correct the situation. It also works as a safety device: should the max./min. 
limit flow be exceeded/not achieved, the pump station switches off. This could 
happen in the event of a leaking pipe or a pump running against a closed 
shut-off valve. 

 

 

 

Please follow producer's installation and operation instructions for 
sensors. Do not activate any devices that have not been installed! 
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Wiring diagram 

 
Connecting Example: 
 
Pressure sensor type:  Kobolt, type 3373.078.092 
    Output 4-20 mA 
    Measuring range 0-25 bar 
 
Measuring: The nominal metering range (e.g. 0-25 bar) is linearly detected and 

converted into a 4-20 mA signal. This means that 1 mA = 1.56 bar.  
 
Scale:    The scale value is 1.56  
 
Offset:    The offset value is -6,24  
 
 

 

You can check the correct functioning of your pressure sensor in the Service 
> General menu. The left column displays the current values on analog 
outputs. If your pressure sensor is connected according to the above 
diagram, the Analog 2 line should display a value of 4 mA. 
If no value appears there, check the connection polarity. Then check whether 
the displayed values in mA change together with pressure changes. If they 
do, then the pressure sensor is connected correctly.  
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To register a pressure sensor, proceed as follows: 
 
In the main menu: 
 

1. Setup Settings  

 Satellites 
  

Go to the Setup > Satellites > Settings menu. 
 

 

 

2. Satellite  Choose the satellite to which the pressure sensor is connected. 
 

3. Scale 

 
Click the Scale field in the S6 P/l Pressure line.  

, 

4. 

 

 

Key in the calculated scale value. 

Calculate the scale value as described in the above example. 

 

5. Save Click the Save button. 
 
 

Registering the offset value 
 

6. Offset 

 
Click the Offset field in the S6 P/l Pressure line.  

 

7. 

 

 

Key in the calculated offset value. 

 

Remember that the minus sign needs to be included some 
cases, [-]6.24, for example. 

 

8. Save Click the Save button. 
 
 

 

 

Print 
Click the Print button to print all the entered parameters by means of a 
connected printer. 
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7.3.3 Connecting an Anemometer (Wind Sensor) 

 
With the help of this sensor (anemometer), you can learn, 
whether you should interrupt your irrigation process due to a 
strong wind causing great losses. 

 

 

 

Please follow producer's installation and operation instructions for 
sensors. Do not activate any devices that have not been installed! 

 
Wiring diagram 

 
Connecting Example: 
 
Wind sensor type: Thies – Clima company 

Windgeber - compact 
Ord. No.: 4.3519.00.141 
Output: 4-20 mA 
Range: 0-50 m/s 

 
Measuring:   As specified on the anemometer  
     0 – 50 m/s converted into a 4 – 20 mA linear signal 
 
Scale: Based on these values, the scale value can be calculated, which is to 

be entered in the S7 line in the Setup > Satellites > Settings menu.  

    Scale: 
ma
sm

)420(
/50


= 3.125 

mas
m

 

Then calculate the offset value, which is also to be entered in the S7 
line in the Setup > Satellites > Settings menu. 

 

    Offset: 4 mA × 3.125
mas
m

 =  -12.5 

 
By this, you have entered all the necessary values for Perrot Satellite 
to measure the wind speed and to record it on the screen of the 
Irrigation > Schedule > Edit menu.  
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To register the wind sensor values, proceed as follows: 
 
In the main menu: 
 

1. Setup Settings  

 Satellites 
  

Go to the Setup > Satellites > Settings menu. 
 

 

 

2. Satellite  Choose the satellite to which the wind sensor is connected. 
 

3. Scale 

 
Click the Scale field in the S7 V/l Wind speed line.  

 

4. 

 

 

Key in the calculated scale value. 

Calculate the scale value as described in the above 
example. 

 

5. Save Click the Save button. 
 

6. Offset 

 
Click the Offset field in the S7 V/l Wind speed line 

 

7. 

 

 
 

Key in the calculated offset value. 

 

8. Save Click the Save button. 
 
 

 

 

Print 
Click the Print button to print all the entered parameters by means of a 
connected printer. 
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7.4 Irrigation Control by External Sensors/Devices 

 
The external devices (sensors) display measured climatic parameters or technical 
values when the system is in the passive mode. These include: 
 precipitation 
 wind speed 
 pump pressure  
 flow 
 custom-defined values. 

 
If these external sensors are activated, you can use them to interrupt the irrigation 
process in the event of exceeding the predefined maximum values. 
 
To activate an external sensor, tick the tickbox of the required sensor (S3 to S8). 
 

 
Editing the settings 
 

 

 Note: Activated sensors must have previously registered their names, 
their scale and offset values. 

 Make sure that you define realistic limit values. Otherwise the irrigation 
would be interrupted unnecessarily. 
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7.4.1 External Sensors for a Weather Station  

 
Sensors S3, S4, S7, S8, S9 and S10 have been designed for 
climatic parameter metering. 
S3 and S4: digital inputs for rain sensors (see chapter 7.2) 
S7 and S8: analog inputs for wind sensors (see chapter 7.3) 
S9 and S10: frequency inputs, which can be used for wind 
sensors among others (see chapter. 7.3). 

 

 

 

Mean values are calculated by Perrot Satellite from values received through 
analog or frequency inputs, so that random short-term excess of the limiting 
values does not interrupt irrigation. 
However, an automatically running program does interrupt if the limiting value 
of a predefined active sensor is exceeded. 

 
The irrigation status shows: "interrupted by weather station”   
if irrigation is interrupted by the rain or wind sensor. 
 
Then Perrot Satellite checks the time entered in the Weather parameter timeout 
(min) field (see also chapter 7.2) if it can resume the irrigation, provided the value is 
back below the limit:  
If so: Irrigation resumes, provided that this time shift (delay) does not cause 
overlapping with the next planned irrigation program. Should this be the case, the 
original program pauses and the next planned program runs first. 
If not: The program pauses and the next planned program only starts after the 
measured value drops below the limit. 
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Acceptable values: 0 – 999 min 
Standard:  60 min. 
 

 

The weather station does not consider manually opened valves or 
manually started programs. Do not activate any sensors that have not 
been installed! 
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7.4.2 External Sensors for Device Monitoring (S5/S6) 

 
 S5 and S6 are analog inputs for flow and pressure sensors (see chapter 7.3). 

 

 Limiting value, editing the settings 
 

 

 Note: Activated sensors must have previously registered their names, 
their scale and offset values. 

 Make sure that you define realistic limit values. Otherwise the irrigation 
would be interrupted unnecessarily. 

 
If limit values are exceeded in sensors S5 or S6, it has probably been caused by a 
mechanical defect in the equipment (broken pipe, close shut-off valve, faulty valve, 
etc.). Irrigation is interrupted in such a case (to protect the equipment and the pump 
station). 
 
The irrigation status line shows: "Error S5/S6"  
 

 

Irrigation is interrupted only if the limit value has been exceeded for more 
than 60 sec. 

 
The system error displays in the red-highlighted line under the Service > Error 
handling > Acknowledge menu.  
You can reset the error only by clicking the Acknowledge all button. This restarts 
the VCU and deletes the error. 
 

 
Obviously you have to detect the source of the error and remove it first. 
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Accept all 
 
 

7.5 Pump Monitoring for Errors  

The pump station control may be equipped with an overall error reporting system. 
The moment the pump station switches off for whatever reason, a general error is 
reported. 
Thanks to the pump monitoring feature, this error can be reported to the Perrot 
Satellite software through a bidirectional decoder. 
 

7.5.1 Setting the Pump Monitoring  

To set the hardware for pump monitoring, proceed as follows: 
 
 Bidirectional decoder programmed with the number 245. 
 Closing relay at the pump control. The relay must operate in the following way: 

  
    - No errors   – contact is open  
    - General error   – contact is closed 
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No errors at Pump System: 
 The pump-state-signalling relay has the contact open and the bidirectional 

decoder measures resistance values on the blue and red loop cables higher 
than 1000 Ohm. This state is registered by the system as Pump OK. 
 
State: No errors 
 

 
Error at Pump System: 
 The pump-state-signalling relay has the contact close and the bidirectional 

decoder measures resistance values on the blue and red loop cables lower 
than 10 Ohm. This state is registered by the system as Pump error. 
 
 
State: General error 

 

Bidirectional 
decoder 245 

Bidirectional 
decoder 245 

Pump status relay 

Pump status relay 

blue 

red

blue 

red
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To use this functionality, the following data must be entered: 
 
In the main menu: 
 

1. Irrigation Edit  

 Parameters 
  

Go to the Irrigation > Parameters > Edit menu.  
 

 

 
Pump supervising decoder              activate             Enter decoder number 

 
 

2. Satellite  Choose the satellite to which the decoder is connected.  
 

3. 

 

 
Key in the number of the decoder installed to supervise the pump. 

 

4. Activate 

 

Activate the function by ticking the Activate pump supervision 
decoder tickbox. 
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7.5.2 Emergency Call in Case of Pump Error  

Should a pump error occur, you can have it reported by phone. 
To set up the emergency call function, proceed as follows: 
 
In the main menu: 
 

1. Setup Emergency call  

 Options 
  

Go to the Setup > Options > Emergency call menu. 
 

 

 

2. Phone number 

 
Click the Phone number data field. 

 

3. 

 

 
Key in the required telephone number. 

 

4. Save 

 
Click the Save button.  

 

5. Test call 

 
Check the connection by clicking the Test call button. 

 

 

 The phone connection works only if your PC is connected to the 
Internet. 

 The called party receives only a call – no voice message.  
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8 Graphic Overview 

8.1 Description 

Perrot Satellite offers a graphic presentation of the irrigated area under the 
Irrigation > Surveillance menu. The displayed area is scaleable, the picture has 
to be provided in dwg format.  
Your dwg picture needs to be converted into svg format by the "Dataslinger" 
program. Then the svg file can be installed in Perrot Satellite as described in 
chapter 8.2. 
 
Regnerbau Calw GmbH can prepare such a graphic form of irrigated areas for its 
customers based on their raw materials and send them the final svg file(s) back on 
a CD. 
 
Interactive valve symbols (icons) can be placed on the graphic image by the user. 
These symbols indicate closed/open valves according to the particular irrigation 
program. In addition, the user can activate (open) a chosen valve manually by 
clicking its icon. 

 

  
 

Active irrigation station:   

Passive irrigation station:  
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8.2 Converting and Inserting a Graphic Image 

 

 

You need to have technician rights to insert graphic images in Perrot 
Satellite. 

8.2.1 Converting Graphic Files 

After you receive a graphic file(s) of your area to be irrigated from your project 
designer (on a CD, for example), you have to convert and insert this graphic image in 
Perrot Satellite. Do the following: 
 Start Perrot Satellite  
 Start Satellite Browser  
 Insert medium with graphic data (CD) in your PC  
 Maximise the Perrot Satellite window  
 

1. Options menu Go to the Options > KK 
SVG Convert menu.  

 
 

2. 
KK SVG 
Convert 

Click the SVG file field. 
A dialog box opens. 

 

3. Choose file 
Find your SVG file 
containing your graphic 
image and click it. 
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4. Open SVG file Click the Open button. 

 

5. 
 

Convert 

The dialog box 
automatically offers 
the target directory 
where the converted 
file will be saved. 

 

 

This directory must not be changed! 

 

6. Convert Click the Convert 
button.  

 

7. Finish 

This information box 
opens after the 
conversion is 
successfully 
completed. Confirm it 
by clicking the OK 
button.   
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8.2.2 Inserting a Graphic Image 

 

 

You need to have technician rights to insert graphic images in Perrot 
Satellite. 

 
In the main menu: 
 

1. Setup Settings  

 Course 
  

Go to the Setup > Course > Settings 
 

 

 

 

2. Course  Choose the course to which you want to assign a graphic image in the 
Course combo-box.   

 

3. File Name  Choose the corresponding graphic image file in the File name combo-
box and save it by clicking the Save button. 

 

 

Only converted SVG files saved in the 
"C:\\Inetpub\wwwroot\websatellite_final\graphics" can be selected! 
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8.3 Placing Valve Icons in Graphic Image 

To place valve symbols, proceed as follows: 
 
In the main menu: 
 

1. Irrigation Overview  

 Surveillance 
  

Go to the Irrigation > Surveillance > Overview menu.  
 

 

 

2. Course  Choose the course to which your want to place valve icons in the 
Course combo-box.  

 

3. 
 

Edit 
Click the Edit button  
All valves of this course will be written in the Valve combo-box. 

 

4. Valve  Choose the valve you want to place in the graphic image by clicking it 
in the Valve combo-box. 

 

5. 
 

Add Click the Add button. 
 
 

 

The valve icon appears in the top left picture corner. 

 
 
 

6. 

 

Position valve 
icon  

Click the valve icon and drag it (i.e. click and keep the mouse button 
pressed) to the required position in the image. 

 

 

If you want to zoom the image in, keep the Ctrl key on your keyboard pressed and mark the 
part of the image you want to enlarge with the mouse, having its left button pressed. Once 
you release the mouse button, the marked area appears as the enlarged image (a cut-out 
from the original image). 
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Marked area for enlarging (zooming in) 

  

 

Enlarged cutout 
 

 

You can move the zoomed cutout on the screen by holding the Alt key on your keyboard 
pressed and by clicking the image and dragging it in the required direction. 

 

 

If you want to reduce the enlarged image, click it with the right mouse button, and choose 
Zoom out or Original View in the context menu. This will zoom the image out – back to the 
original size (scale). 
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Once you have placed all the valves in the image, you can leave the editing mode. 

 

8. 
 

Overview Exit the editing mode by clicking the Overview button. 
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8.4 Manual Opening of Individual Valves 
 

1. Irrigation Details  

 Surveillance 
  

Go to the Irrigation > Surveillance > Overview menu. 
 

 

  

2. Valve  
Choose the valve you want to open manually.  
1.) Click the Valve combo-box and choose the required valve.  
or 
2.) Click the required valve icon in the graphic image. 

 

 
Only valves positioned in the graphic image are listed in the Valve combo-box. 

 

3. Time (min) Key in the required time (duration) for the selected valve to stay open.  

 

4. Open Click the Open button. This opens the valve for the duration as specified 
in the Time (min) field. 

 

5. Close Click the Close button. This closes the valve immediately. 
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8.5 Displaying the Current Valve Status  

Once you choose a pump system, Calculated water consumption displays its 
value, which is the sum of all active valve consumptions. The Efficiency rate informs 
of the relative pump use compared to its nominal performance. It should not exceed 
100% for a prolonged period. 
 

 
Pump system  Calculated water consumption Efficiency rate. 
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8.6 User Information on Irrigation Process 

The Irrigation > Surveillance > Details menu informs the user of all steps 
performed as part of the currently running irrigation program. 
 

 
 

 Course  
(down arrow) 

 Choose the course for which you want to see information about the 
currently running program. 

 

 
Name This column shows the valve name. 

  

 
State  This column shows whether the valve is open or closed. 

 

 
Status  

"Auto" if the valve is opened by the program 
"Manual" if the valve is opened manually in the graphic 
image, through a transmitter or from a PDA.  

 

 
Remaining time  

This column shows the remaining time for which the valve is 
to be open.  

 

 
Error Error reporting – only with bidirectional decoders. 

 

 
Program 

This column lists all the currently running irrigation programs 
at all courses. 

 

 
Pumpsystem See chapter 8.5. 
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Close valve 

By clicking this button, you can close the valve selected in 
the table immediately, regardless of its remaining time. 

 

 
Close all valves 

By clicking this button, you can close all the currently open 
valves. 

 
 

 

In order to see the current system state on this screen, you have to click the Update 
button. Only then will the latest state appear. 
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9 Remote Access from the Internet  

 

9.1 Description and Communication Diagram  

Perrot Satellite is irrigation control software built on the Internet technology platform. 
Thanks to this program architecture, the software can easily be operated through a 
web browser (Internet Explorer, for example) and can be operated remotely.  
The software is installed on a control PC which works as a server. 
 
Remote access from another PC (desktop or laptop) is possible through: 
 Internet with a fixed IP address of the server PC or through the "dyndns.org" 

service. 
 

Remote access from a PDA is possible through: 
 the Internet (GPRS, for example). 

 
 

  

Control PC 
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9.2 Remote PC Hardware and Software Requirements 

 
 Min. AMD Athlon 64 or Intel Pentium 4, min. 1GHz 
 Min. 1,024 GB RAM, approx. 40GB free hard disc space 
 Windows XP Professional SP2 with Net Framework and IIS installed 
 Microsoft Internet Explorer 6.0.28 or newer 
 Network card: Ethernet 100 Mbit 
 VGA colour monitor, resolution 1024 x 768 
 laptop wide resolution 1280 x 800 

 
 

9.3 Perrot Satellite Remote Control over the Internet 

 
Remote Control Conditions 
 The Perrot Satellite server must be permanently connected to the Internet.  

 A T-DSL Flatrate connection is recommended. 
 
 The Perrot Satellite server must have a fixed IP address (can be bought for a 

low charge together with the T-DSL Flatrate connection). 
 
 The server must have Perrot Satellite running (Internet Explorer, however, 

does not have to be open). 
 
 Now you can access Perrot Satellite from a remote client PC (desktop  

or laptop) connected to the Internet. Type the following address in Internet 
Explorer:  
http://[fixed IP-Address]/WebSatellite_final/Login/PageStartLoginPC.aspx 
where [fixed IP-Address] is the fixed IP address given to you by your internet 
provider. 

 
 Perrot Example  

For demonstration purposes, let's try to establish a connection to the internal 
Perrot server: 
http://87.139.50.247:10000/WebSatellite_final/Login/PageStartLoginPC.aspx  

 

 
Your Internet access should be set up by your system administrator. 

 
You can perform all activities and use all functions of Perrot Satellite through the 
Internet as you would do them directly on the control PC, i.e. without any limitations. 
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9.4 Perrot Satellite Remote Control over from PDA 

9.4.1 Establishing a Connection 

Perrot Satellite can also be controlled from a PDA connected to the Internet. Type 
the following address in Internet Explorer: 
 http://[fixed IP-Address]/WebSatellite_final/Login/PageStartLoginPDA.aspx  
where [fixed IP-Address] is the fixed IP address given to you by your internet 
provider. 
 
You can perform all the control functions from your PDA such as opening/closing of 
valves, auto on/off, and learn system status information. These functions are 
important especially if checking/controlling the system in the field. 
You cannot enter any valve data from a PDA. 
 

9.4.2 Manual Valve Opening from PDA 

The most important function for the field control is opening of individual valves. It is 
done as follows: 
 

 

Through the web’n’walk function, open 
Internet Explorer in your PDA and 
establish a connection with your Perrot 
Satellite server.  
 
Enter your username and password and click 
the Login button. 

 

 

It is recommended to set the link to Perrot Satellite either as your 
homepage or save it as one of your favourite links. 
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Choose the Single valves option in the main 
menu. 

 

 

To speed the valve selection up, click the 
Select function. 

 

  
 

Using the  key, you can now choose one of the Selection names previously saved 
in the server PC. 
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If you want to see Green A in the Valve 
selection menu, for example, you have to 
tick the Selection tickbox.   
 
All ticked selection names will be displayed in 
Manual control and in Valve selection, as well 
as valves with no selection name. 
 

 

 

Note: The window must be redefined after each selection, i.e. after 
each click. If you click too quickly, not all defined selections may save 
properly. 

 

 

Once you have all names selected, keep 
clicking the Back function, until you return to 
the Manual control page. 

 

 

Using the  key, you can select all ticked 
valves with selection names as well as valves 
without a selection name.  
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Once you have a valve selected, you can set 
the time for which the valve should stay open. 

Use the  key. 

 

 

Click the Open button to open the valve 
immediately. Should you want to close the 
valve prematurely, click the Close button. If 
you have opened more valves and want to 
close them all, click the Close all button. 

 

 
Use the "Zoom" submenu to enlarge the data to the required size. 
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Other PDA menus such as Auto control, Error handling and Status 
information operate the same way as in the main software and 
therefore do not require further explanation. 

 
 

9.5 Perrot Satellite Checklist for Internet Remote Access 

 
Hardware and Software Requirements 
 Min. AMD Athlon 64 or Intel Pentium 4, min. 1GHz 
 Min. 1,024 GB RAM, approx. 40GB free hard disc space 
 Windows XP Professional SP2 with Net Framework and IIS installed 
 Microsoft Internet Explorer 6.0.28 or newer 
 RS 232 (COM1) serial port for connecting the VCU 
 Network card: Ethernet 100 Mbit 
 VGA colour monitor, resolution 1024 x 768 
 Laptop wide resolution 1280 x 800 

 
Remote Control Conditions 
 The Perrot Satellite server must be permanently connected to the Internet.  

Recommended is a T-DSL Flatrate connection. 
 
  The Perrot Satellite server must have a fixed IP address (can be bought for a 

low charge together with the T-DSL Flatrate connection). 
 
  The server must have Perrot Satellite running (Internet Explorer, however, 

does not have to be open). 
 
  Now you can access Perrot Satellite from a remote client PC (desktop  

or laptop) connected to the Internet. Type the following address in Internet 
Explorer:  
http://[fixed IP-Address]/WebSatellite_final/Login/PageStartLoginPC.aspx 
where [fixed IP-Address] is the fixed IP address given to you by your internet 
provider. 

 
  Perrot Satellite can also be accessed from a PDA connected to the Internet. 

Type the following address in Internet Explorer: 
http://[fixe IP-Adresse]/WebSatellite_final/Login/PageStartLoginPDA.aspx 
where [fixed IP-Address] is the fixed IP address given to you by your internet 
provider. 
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  If you do not have a permanent IP address established, you can access Perrot 

Satellite using the "DynDNS" service (more information at 
http://www.dyndns.org). If you have a professional router available, this router 
will provide an automatic IP address update through the "DynDNS" service. If 
you do not have a professional router, you have to use the "DynDNS Updater" 
program to update the IP address. 

 
  Perrot Example  

For demonstration purposes, let's try to establish a connection to the internal 
Perrot server:  
http://87.139.50.247:10000/WebSatellite_final/Login/PageStartLoginPC.aspx  
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10 Transmitter 

10.1 Remote control via the transmitter TM1 

The hand terminal consists of a 2 x 16-stelligen digital display and 7 function keys. 
The communication as well the power supply occurs by the 2-wire decoder cable. 
The plug has to be connected with the field connector. 
 
The transmitter provides following functions: 

 Valve open 
 Valve immediately clos 
 All valves immediately close 

 
 
The transmitter will be connected with the 2-wire cable 
system via the field connector. 
After the transfer of the station names the Transmitter  
can be used at all field connectors. 
  
  
Clear identification of the valve names by text  
Indicator e.g. 18 – Green 9  
 
After setting the valve opening time the 
Transmitter can be disconnect from the field 
connector. 
Information call informs you about:  
   

 Irrigation status 
 Condition of each decoder 

(open/close) 
 Emergency stop function – to 

switch off all irrigation activities 
 
 
 
 

 

You can find further details in the user manual  TDP063e (Transmitter TM1). 
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10.2 Remote control via Wireless Transmitter 

The WT allows the communication with the control system about an autarkic radio 
network. The radio network will be installed at site (see picture – scheme drawing). 
With a free view to the antenna a coverage up to 2km is possible. If there is any 
obstacle due to the area, buildings or trees you can expand to the requested 
coverage with the installation of additional repeater stations. The WT can be used in 
all European countries without radio license. 

 
 
 
Application 
The WT is very robust and easy to use with just 5 buttons. Ideal for manual watering 
and for function tests of the system. 
Functions 
Open and close the valves with adjustable time standards. Start and stop the 
irrigation programs.  
Easy valve searching by choosing different criteria. Automatic synchronisation of the 
valve- and program data, 3-digit LCD display for menu navigation and super support. 
 

 

You can find further details in the user manual TDP061e  
(Wireless Transmitter for Perrot Satellite). 

WBU 
base unit 

VCU for 
Greenkeeper 
control system

PC with Perrot 
Satellite 

control system 
 

Antenna 
 

Cable interface 

Antenna 
cable 

Wireless 
transmitter 
 

Power 
supply 
unit
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11 Reports  

 
All irrigation steps are saved in the PC. Perrot Satellite software can process the 
data of these steps and provide them in the form of various reports. 

 
There are three types of reports available: 

11.1 Irrigation Reports 

 
 
 1. Irrigation Program Report 
  The report lists all valve activities that occurred in the last programs. 
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Course name:   The name of the course 
 

Report name:   Irrigation program name 
 

Start time:   Starting time of the irrigation program 
 

Stop time:   Time of finishing the irrigation program 
 

S9:    Name and value of frequency input 1 
 

S10:    Name and value of frequency input 2 
 

Position:   Sequential No. 1-1600 (480 per Single/Sector program) 
 

State:    Valve status, 2 per valve, on/off 
 

Valve name:   Name of the valve 
 

Time:    Time at which the reported event happened 
 

Valve status:   This reports correct [OK] or erroneous valve status  
(in case of bidirectional decoder) 

 

S5 flow:   Report from a V/I flow meter 
If a flow meter is installed, this reports the real flow at the 
given moment.  

 

Estimated flow:  Flow as calculated from the entered data. 
 

Pressure:   Report from a P/I pressure meter 
If a pressure meter is installed, this reports the real pressure 
in bars at the given moment  
 
 
 

 2 Yearly Report 
This report lists the overall precipitation, water consumption and opening time for each 
valve in the whole year. 

 
 

 
 

 
 
 3. Snapshot Report 
  This report lists all the currently active valves and irrigation programs. 
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11.2 Irrigation Program Report  

 

 
All users can view and/or print these reports! 

 
To display/print a report, proceed as follows: 
 

1. 
Reports 
Irrigation 

  

Go to the Reports > Irrigation > Irrigation programs menu. 
 

 

 

   
 

2. Course  Choose the course for which you want to print your report. 
 

3. Report 
selection  Choose the irrigation program for which you want to print your report. 

 

 

The report lists all changes of valve status (on/off). 

 

 

The screen displays the selected course. 
Each event is marked with a sequential number and valve information. 

 

 

You can go to the following screen (page) by clicking the Next button. 
You can go to the previous screen (page) by clicking the Prev button. 

 

4. 
 

Print Click the Print button to open the print preview of the report. 
 

5.  
Click the printer button to print the displayed report in the printer connected 
to your PC. 
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11.3 Yearly Report 

 

 
All users can view and/or print these reports! 

 
To display/print a report, proceed as follows: 
 
 

1. 
Reports 
Irrigation 

  

Go to the Reports > Irrigation > Yearly menu: 
 

 

 

   
 

2. Course  Choose the course for which you want to print your report. 
 

3. Year  Choose the year for which you want to print your report. 

 

 

The screen displays the yearly report for the selected year. 
The report displays the overall precipitation, water consumption and opening time for each 
valve – for the whole year. 
The bottom Total line displays sums of all the above annual values. 

 

 

You can go to the following screen (page) by clicking the Next button. 
You can go to the previous screen (page) by clicking the Prev button. 

 

4. 
 

Print Click the Print button to open the print preview of the report. 
 

5.  
Click the printer button to print the displayed report in the printer 
connected to your PC. 
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Data Export 
 

 
You need to have technician rights to backup data from Perrot Satellite. 

 

 

You can export the selected report in a different format. 
Once your data is exported in the .CSV format, you can open your report and edit it in MS 
Excel, for example. 

 

 

1. 
 

Export Click the Export button to save the selected report as an .CSV file. 
 

2. Saving 

 
The exported .csv file will be saved in the C:/PerrotSatellite/Export/ 
directory. 

 

 

Individual values can be separated (delimited) with a comma or with a semicolon in the 
exported .csv file. When you then open the file in MS Excel, you have to specify the 
separator used. 

 

3. Excel Now you can open your exported file in Microsoft Excel. 
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11.4 Program/Valve Snapshot 

 
To display the active irrigation programs and valves, proceed as follows: 
 
In the main menu: 

1. Reports  Snapshot 
 

 

Irrigation 

 
The Program column lists all currently running irrigation programs. The 
Valve name column lists all currently active valves. 

 

2. Update Click the Update button to update the lists on this screen. 
 

3. 
 

Print Click the Print button to open the print preview of the report. 
 

4.  
Click the printer button to print the displayed report in the printer 
connected to your PC. 
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12 Data Backup  

 
By means of the backup function, you can save all user-entered data (e.g. pump 
data, valve data) and software-related data (e.g. irrigation programs, interval values) 
in a single file located in a subdirectory under the Perrot Satellite directory. 
In an emergency, you can restore the backed up data (i.e. load it back to the 
system), so that the irrigation system runs in the normal way again. 
For this reason, it is vital to back up your data after each important change in the 
Perrot Satellite software (e.g. after a system data modification). 
We recommend to also back up your data externally (to a CD or a USB flash disc) 
just in case your hard disc or the whole PC collapses. 
 

 
Backup your data after each data modification!!! 

 

12.1 Backing up Your Data 

 
 
To backup your data, proceed as follows: 
 

12.1.1 Stopping Perrot Satellite software 
 

1. Perrot Satellite Stop Perrot Satellite 
 

 

Stop the software 
Go to the File menu 
and click the Stop 
item. 

                 Status 
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2. Stop the software 
Click the Yes 
button.  

 

 

Stopping the software takes some time. Stopping… 
appears in the status line in the bottom left corner of 
the Perrot Satellite window. The software is stopped 
at the moment this message changes into Stopped.  

 
 

12.1.2 Executing the Backup Function 
 

1. 
Perrot Satellite 
Database menu 

  

Go to the Options > Database menu. 
 

 

Choose data 
backup 

Go to the Options menu and 
click the Database item. 

 
 

2. Choose Backup 

 

Click the Backup button. 

 

3. Choose file name 
and target directory  

Choose a name and a directory for your backup file in the dialog box 
that opens. 
The name of the file should always contain the date of its saving. 
We recommend not to change the proposed file name and target 
directory and to save the file with these settings. 
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4. Save 
 

Click the Save button. 
This creates a backup file [.bak] in the selected directory.. 

   

 

5. 
 

OK Leave the database menu by clicking the OK button. 

  

 
 

 
To protect your data in case of your PC collapse, save it externally, too. 

 

12.1.3 Starting Perrot Satellite software 
 

1. Start the software Go to the File menu and click 
the Start item. 

 

 

Starting the software takes some time. Starting… appears 
in the status line in the bottom left corner of the Perrot 
Satellite window. The software is ready to work again at the 
moment this message changes into Started.  
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12.2 Restoring your Data 

 
 
To restore your data from a backup file, proceed as follows: 

12.2.1 Stopping Perrot Satellite software 
 

1. Perrot Satellite Stop Perrot Satellite 
 

 

Stop the 
software 

Go to the File menu and click 
the Stop item. 

 

2. 
Stop the 
software 

Click the Yes button.  

 

 

Stopping the software takes some time. Stopping… 
appears in the status line in the bottom left corner of the 
Perrot Satellite window. The software is stopped at the 
moment this message changes into Stopped.  
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12.2.2 Executing the Restore Function 
 

1. 
Perrot Satellite 
Database menu 

  

Go to the Options > Database menu.  

 

Database Go to the Options menu and click 
the Database item. 

 
 

2. 
Choose 
Restore 

Click the Restore button. 

 

3. Choose directory 
and file name 

Choose the latest file in the corresponding directory in the dialog box 
that opens. You can tell the latest file by its saving date. 

  

 

4. 
 

Open 
Click the Open button. 
Perrot Satellite data will be restored from the selected backup file [.bak]. 
All the current software data will be overwritten. 

 

5. Overwrite data? 

  
Click the OK button. 

 
 

6. 
 

OK Leave the database menu by clicking the OK button. 
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12.2.3 Starting Perrot Satellite software 
 

1. 
Start the 
software 

Go to the File menu and click the 
Start item. 

 

 

Starting the software takes some time. 
Starting… appears in the status line in the 
bottom left corner of the Perrot Satellite window. 
The software is ready to work again at the 
moment this message changes into Started. 

 

 

 
All the data and settings should be checked after a data restore! 
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13 Decoder 

 

13.1 Decoder Programming 

 

 
You need to have technician rights to program a decoder! 

 

 

You must program each decoder to a correct address (number) before 
installing it. 

 
Perrot Satellite allows you to freely choose decoder numbers for valves, pumps and 
pump monitoring. Yet, it is recommended to use the following numbering system to 
make it easier to survey: 

Decoder number  1 .. ....240   for valves 
Decoder number  241 .. 250   for pumps 
Decoder number  251    for pump monitoring 

 
 
Decoder Types: 
 
Description Type code Features Application 

Standard decoder PD5/AC-1 
Red square box,  
4 connecting cables 

To control 1 station 

Decoder for 4 
stations 

PD5/AC-4 
Red square box,  
10 connecting cables  

To control 4 stations 

Decoder for 6 
stations 

PD5/AC-6 
Red square box,  
14 connecting cables  

To control 6 stations  

Bidirectional 
decoder 

PDF/-1 
Black square box,  
4 connecting cables  

To control 1 station 
with valve state 
feedback  

 

 
All decoders can be reprogrammed as many times as needed. 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 157 / 180 

 
A. To program a decoder, you need the following components: 
 
 PC with the Perrot-Satellite software installed, and VCU 
 DPG programming unit - FB (part No. ZH90022) or  

DPK programming cable (part No. SG50032) 
 Decoder 

 

B. Preparation for decoder programming 
 
Open the VCU door. 
 
Plug the programming unit connector to terminals 34 and 35 on the VCU bus. The 
decoder cable (6-pole connector) must be disconnected. 
 

 
Programming unit 
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Go to the Service > Satellite > Decoders menu. 
 
In the main menu: 
 

1. Service  Decoders 
 

 

Satellite 

 
 
Description  
 
 Each point has a decoder number on the right-hand side. The meaning of 

different colours is explained on the right of the screen. 
 Satellite choice: Choose the satellite, to which you want to connect the 

programming unit, in the Satellite combo-box. 
 Activate/deactivate buttons: The selected decoder will be activated or 

deactivated by clicking the corresponding button. 
 Inrush/Hold current: Depending on the characteristics of the coil switched by 

the decoder, higher or lower current must flow through the coil to provide 
reliable coil functioning.  

 Electrical current values can be set at 4 levels: high, standard, medium or low. 
Depending on this setting, the decoder sends higher or lower level of the 
inrush or hold current to the coil.  

 Do not exceed the recommended operating range described in the table in 
chapter 13.4, while programming.  

 Use the Program button to program the decoder. 
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Programming successful 

          
Ready to program 

                    
Decoder is active

 
C. Programming with DPG Unit (part No. ZH05 90022) 
 

1. Connect the programming unit to a new decoder. 
Red cable   to the red terminal 
Blue cable  to the blue terminal 
Always 1 black cable to the black terminal.  
 

2. Switch the unit controller to the central position. 
 

3. Click the radio button of the required decoder number on the screen.  
By this, you have selected the required decoder. A black dot appears inside 
the radio button (i.e. the white circle). 

 
4. Click the Program button. 

 
The LED on the decoder turns on. 
 

 
 
 

5. Wait for at least 2 seconds, then press the unit controller upwards to the 
"Program" position and keep it pressed  for 2 seconds. 
By this, you have saved an address (a number) in the decoder. 

 
The LED on the decoder should blink 5 times briefly. 

 
 
 

Should the LED fail to respond, repeat the programming procedure starting 
with step 4. 

  
To test the programmed decoder, press the unit controller downwards to the 
"Test" position. 

 
Click the Activate button on the screen. 
The decoder is activated when the LED on the unit (COIL ON) is on and the 
decoder blinks in the following rhythm: 

  
 
 

 
To terminate, click the Deactivate button. 
The decoder is now prepared for installation. 
Do not forget to write the selected number on the decoder!! 
To program further decoders, repeat the whole procedure. 
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Programming successful 

          
Ready to program 

 

 

If electrical current flows into a decoder for longer than 5 minutes, the 
programming protection turns on automatically. You can only continue 
programming after the decoder has been without the current for some 
time. 

 
 
D. Programming with DPK Cable (part No. CGA9 50032) 
 
Proceed the same way as in section C. 
 

 Connect programming cable terminals with 1 black cable from the 
decoder. 

 
 Click the required number  

By this, you have selected the required decoder. A black dot appears 
inside the radio button (i.e. the white circle). 

 
 Click the Program button. 

 
The LED on the decoder turns on. 

 
 
 

 Wait for at least 2 seconds. Then interconnect the red and the blue 
decoder cables. 
Now you have saved the address (number) in the decoder. 

 
The decoder LED should respond by 5 short blinks. 

 
 
 

 
Should the LED fail to respond, repeat the whole programming 
procedure. 

 

 

No functionality check can be done with the Programming cable. 
Should you need to perform a functionality check, you would have to 
connect a coil to the red and blue decoder cables. 

 
To program further decoders, repeat the whole procedure. 
Do not forget to write the selected number on the decoder!! 
 

 

Standard decoder type:   PD5/AC-X (incl. MultiDecoder) 
Part No.:    ZH05 90033 + ZH05 90377 + ZH05 90378 
from production date:  12-04 
is programmed the same way as the FB decoder. 
This decoder type can also be reprogrammed as often as needed. 
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13.2 Programming Bidirectional Decoders 

Bidirectional decoders are programmed the same way as standard decoders.  
Warning: Once you connect the programming unit to the decoder, start programming 
as soon as possible. Otherwise the repeated error registration would find out that no 
coil has been connected, which could have negative effects on the programming 
process. 
 

  
 
 

Normal operation 

Operation with Error 

Pause time 

Valve off – no pressure 
 
Valve on – no pressure 
 
Valve off – pressure exists 
 
Valve on – pressure exists 

Coil short-circuited 
 
No connection to coil 
 
Voltage < 30 V 
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13.3 Decoder List 

The decoder list helps to get an overall view of all decoder-setting values. 
Decoder Irrig. area  Number and type of Water consumpt.  Irrigated Hydraul. 

No. name sprinklers  m³/h area m² sector 
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13.4 Variable current values at standard decoders type PD2-5/AC  
        for Greenkeeper Win and for Perrot Satellite 
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14 Feedback Control 

14.1 Feedback System 

Perrot Satellite can be equipped with bidirectional decoders instead of the standard 
ones (see chapter 13). Bidirectional decoders provide information to the user on 
whether a station equipped with them operates faultlessly. 
A flow sensor, which can be installed in each valve or in each sprinkler is periodically 
asked whether the water flows or not. 
Perrot Satellite then compares the planned and the real states.  
Should a discrepancy be detected, an error message appears immediately.  
 
If Perrot Satellite is equipped only with standard decoders, the signal is transferred in 
one direction only, i.e. from VCU to decoders. 
 

 
 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 165 / 180 

However, Perrot Satellite also supports bidirectional decoders. A bidirectional 
decoder communicates with a VCU in both directions.  
It can receive information and perform orders contained in them. In addition to these, 
a bidirectional decoder can send information on the irrigation station current state 
back to its VCU. 
 

 
 

 
Any system can combine both standard and bidirectional decoders. 

 
A bidirectional decoder and a flow sensor can read all the following states and send 
information about them back to Perrot Satellite: 
 Valve is open 
 Valve is closed 
 Valve coil is short-circuited  
 Connection to valve coil is broken 
 Decoder does not answer 
 Voltage on the decoder is too low 

 
This information helps the user to recognise possible problems before they could 
lead to damaging part(s) of the equipment.  
An error message, however, can appear even at times when the equipment is still 
running without problems. In such a case, it is proactive advance notification of a 
state in which a significant drop of the coil resistance has been detected – even 
though the coil is still operating perfectly and there is still a lot of time before it needs 
to be replaced. Please do pay attention to such messages. It will help you with later 
fault diagnosing. 
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You can set the  
 "If – Then" option 
in Perrot Satellite to automatically interrupt the running irrigation program if a certain 
number of error messages is exceeded. 
 

14.2 Setting up the Feedback System 

14.2.1 Entering Data for Bidirectional Decoder and Pressure Sensor  

The feedback system can only be set for bidirectional decoders. If you have a 
bidirectional decoder or a bidirectional decoder with pressure sensor installed in your 
system, their values are to be entered together with valve data (see chapter 5.8). 
 

 
 
If you want to use a bidirectional decoder, the Bidirectional tickbox must be ticked. If 
you want to use a bidirectional decoder with a flow sensor, the Flowsensor tickbox 
must be ticked. 
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14.2.2 Setting up Feedback  
In the main menu: 
 

1. Setup  Control 
 

 

Options 

 
Max. No. of faulty opened valves permitted 
If the number of the "valve open error” error messages exceeds the limit value 
specified in the Max. No. of faulty opened valves permitted field, the irrigation 
process interrupts. All active programs stop, all manually open valves close. 
The irrigation status changes into "Error". 
Irrigation can only be resumed after the error is acknowledged in the Service > Error 
handling menu. 
 
Acceptable values:  0- 255 
Standard value:   0 (function not activated) 
 
 
Decoder open delay time 
This time specifies for how long the system will accept the "Valve closed" status 
before it sends an error message.  
 
Acceptable values:  15 – 250 s 
Standard value:   30 s 
 
After you have entered the required value, click the Save button to accept the value. 
 

 

It is recommended to set this time to 150 seconds to prevent the 
generation of false error messages. 
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Decoder close delay time 
This time specifies for how long the system will accept the "Valve open" status 
before it sends an error message.  
 
Acceptable values:  15 – 250 s 
Standard value:   30 s 
 
After you have entered the required value, click the Save button to accept the value. 
 
 
"Feedback-decoder settings" Screen Section 
The bidirectional decoder sends a short pulse (5 ms) to the coil approximately each 1 
minute. These pulses test the coil resistance and the correct connection between the 
decoder and the coil.  
Some valves, however, respond so quickly, that they briefly open even after such a 
short coil activation. To prevent this false valve opening at unwanted times, you have 
to set suitable testing times in the Test interval from and Test interval to fields.  
  
 Example : 
 From 01:30 to 03:00  1h 30 min. test duration 

From 22:30 to 01:00  2h 30 min. test duration 
 From 00:00 to 00:00  function is inactive, no test 
 From 00:00 to 23:59  test duration around the clock 
 

 

It is recommended to set the test interval to 60 minutes and to run the 
tests at night times. 

 

 
The entered values must be saved by clicking the Set interval button! 
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14.3 Error Handling in Perrot Satellite Feedback System  

Information sent by a bidirectional decoder back to the VCU can be displayed in the 
Service > Satellite > Log menu: 
 
1. Service  Log 

 

 

Satellite 

 
Perrot Satellite checks whether this information corresponds with the programmed 
irrigation procedure. If it does not, it generates a warning message.  
All warning messages generated can displayed in the following menu: 
2. Service  Acknowledge 

 

 

Error 
message 
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One of the following warning messages is then displayed, reflecting the state 
reported by the bidirectional decoder: 
 Valve is open while decoder XX is closed 
 Valve is closed while decoder XX is active 
 Decoder XX reports short circuit at the valve coil  
 Decoder XX reports no connection to the valve coil 
 No answer on decoder XX  
 Low voltage at decoder XX  

 
These warning messages have no consequences, but rather just inform the user that 
there might be something out of order in the system. We recommend to monitor them 
closely and to track the fault if these repeat.  
 
The following warning message is an exception:  
 

"Valve is open while decoder XX is closed" 
 
If this message appears three times in a row, Perrot Satellite generates an error 
message. In addition to this, if the number of these warning messages exceeds the 
number previously set in the  
 

"Max. no. of faulty opened valves permitted" (see chapter 14.2.2) 
 
field, irrigation is interrupted and "Error" appears in the irrigation status line. 
Other warning messages are not dangerous for the system and therefore do not 
interrupt the irrigation process. 
 

 

These messages are displayed in red in the Service > Error handling 
menu. 
To reset the warning/error message, click the Acknowledge all button, 
which also restarts (initialises) the VCU.  
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15 Service Menu 

15.1 Overview of Measured Values 

The Service > Satellite > General screen presents all electric current values as 
metered by the VCU. The displayed values are raw, i.e. not recalculated with scale 
and/or offset values. 
1. Service  General 

 

 

Satellite 

 

2. Satellite  Choose the satellite, from which you want to display the metered 
values. 

 
Description of fields/values: 
 
Analog 1-4:    Value in mA at the analog inputs 1 – 4 (S5-S8) 
 
Frequency 1-2:   Frequency in Hz (S9+S10) 
 
Earth radiance:   Leakage current from the decoder cables 
 The earth-leaking current must not exceed the 

following values: 
     0.7 A for 8 sec 
     1.0 A for 4 sec 
     1.4 A for 2 sec 
     2.0 A for 1 sec 
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Net consumption:   Current flow through decoder cables [A] 
The current consumption is too high.  
Values must not exceed: 

     2.8 A for 32 sec 
     4.0 A for 16 sec 

The optimum consumption (draw from the mains) 
can be calculated as the VCU consumption (50 mA) 
plus the consumption of all decoders (1 mA each).  
Example:  
A system with 100 decoders should have a standby 
consumption of 150 mA. 

 
Digital 1:    Relay output 1 active/inactive 
Digital 2:    Relay output 2 active/inactive 
 
Out A (V):    Output voltage [V] on decoder cables A 
Out B (V):    Output voltage [V] on decoder cables B 
     Voltage lower than the limit value: 
     Less than 20.0 V for 32 s 
 
Digital 1-2:     Status of the digital inputs 1 - 2 
 
 
LED 1 (yellow):   Irrigation program status  
 
ON:     Irrigation program is running. 
 
BLINKING: Irrigation program interrupted by a weather station. 
 
SHORT BLINKS:   Running program has been interrupted. 
 
LONG BLINKS:   VCU is in waiting mode. 
 
OFF:     VCU error 
 
 
LED 2 (red):    Status of the 2-wire cable 
 
ON:     2-wire cable error (see the VCU status) 
 
BLINKING: No error or the earth radiance value is greater than 

0.25 A. Operation continues. 
 
SHORT BLINKS: 2-wire cable connected, preparing to connect to 

decoders.  
 
OFF:     Correct status, no error. 
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15.2 Decoder Test 

You can perform a passive decoder test in the Service > Satellite > Decoder test 
menu.  
 
This test gives just quantitative information about the decoder functioning. Possible 
problems/faults must be physically checked at their places. 
 
Approximately one minute after a test start, the system starts metering the current 
flowing through the decoder cables.  
This metered current then serves as the reference value. 
The first decoder is activated for the time set as the testing interval.  
During the test, the current on the decoder cables is regularly metered. A mean value 
is then calculated from these metered values.  
The reference value is deducted from this mean value.  
The result is the decoder power drain (consumption). 
All the other decoders are tested the same way.  
 

 

If the decoder and the coil are in order, their power drain is between 10 and 
50 mA. Should lower or higher values be metered, we recommend physically 
checking the decoder. 

 

 

If values (higher or lower) outside the acceptable tolerance are metered, 
the metering process repeats two times. This may significantly prolong 
the whole testing process. 

 
 
 
In the main menu: go to the Decoder Test: 
 

1. Service  Decoder Test 
 

 

Satellite 
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Performing Decoder Tests 
 

1. You can select the decoder to test in three different ways: 
A) Click the All button. This will test all decoders. 
B) Click the Installed button. This will test only decoders marked with the 

red point.  
C) Tick the tick-boxes of the required decoders. 

 

 
You can cancel your selection by clicking the None button. 

 
2. Choose the testing time in seconds: Open the Averaging (sec.) combo-box 

and choose one of the available times. The longer the testing time, the more 
accurate the metered values. 

3. Start the test by clicking the Test button.  
 

 
Do not leave the screen until the test is complete. 

 

 
The LED on the VCU keeps blinking during the test.  

 
 

 

During the decoder test, the pump decoder does not start, but the valves 
physically do open. Please shut the main feeding valve off if you do not want 
the valves to leak water. 

 
Test Results 
 
The current draw (consumption) of individual decoders displays in the Service > 
Satellite > Log menu: 
1. Service  Log 

 

 

Satellite 
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1. Choose the required satellite (VCU) in the Satellite combo-box. 
2. Set the filter section to have only the Decoder Test tickbox ticked. 
3. Click the Refresh button. This will display only the decoder test results. 

 

 

If one or more of the displayed values are out of tolerance, the line is marked 
with an asterisk (*). If this results does not change even after an additional 
two measurements, this decoder will be marked with "ERROR". 

 

 
 
The print preview displays the total number of decoders with out-of-tolerance values 
at the end of the list. 
 

The range of decoder current should be between 10 - 50 mA. 
 

 

Note: If a short circuit occurs on the decoder cables, the test results are 
unreliable! 
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15.3 Viewing the Application Log  

1. Service  Log 
 

 

Application 

 
The screen lists all events generated by the system control. This list is identical with 
the system report log displayed in the box in the header of all Perrot Satellite 
screens. This list, however, saves the events for a longer time and the events can be 
printed out at any time.  
 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 177 / 180 

16 Error Codes 

Incorrect values entered or system problems may cause errors. These are written in 
red on the corresponding screen or can be listed on the Service > Error handling 
screen. 
 
Each error as its own ID number (code). Please specify this error ID number each 
time you contact the hotline. 
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Error codes are listed in the following table: 
 

Error ID No. Description 

1000 Internal error: {0} 

1100 Pumpsystem flow is lower than hydraulic group flow for hydraulic group {0} 

1101 Pumpsystem '{0}' already exists! 

1102 Empty pumpsystem name! 

1103 Pumpsystem does not exist! 

1104 Total pumpsystem flow is lower than current minimum hydraulic group flow! 

1105 Pump does not exist! 

1106 Pump '{0}' already exists! 

1107 Empty pump name! 

1108 Satellite mus be chosen! 

1109 Pump activated not allowed to edit 

1110 Resulting flow for pumpsystem would be smaller than flow for valve '[0]' ({1} m³/h)! 

1111 Pumpsystem is use by programs, not allowed to delete 

1112 
Pump is use by programs, not allowed to delete, Hydraulic group flow exceeds  
pumpsystem 

1200 Hydraulic group flow exceeds pumpsystem capacity ({0} m³/h)! 

1201 Hydraulic group '{0}' already exists! 

1202 Empty hydraulic group name! 

1203 Hydraulic group does not exist! 

1204 Empty hydraulic group name! 

1300 Empty hydraulic sector name! 

1301 Hydraulic sector does not exist! 

1302 Hydraulic sector '{0}' already exists! 

1303 Hydraulic sector flow exceeds group capacity ({0} m³/h)! 

1304 Hydraulic sector flow constraint violation! 

1305 Resulting flow for sector would be smaller than flow for valve '{0}' ({1}m³/h)! 

1400 Empty valve name! 

1401 Valve named '{0}' already exists! 

1402 Valve named '{0}' does not exist! 

1403 Unable to delete valve in use by a valve collection! 

1404 Density must be between 0 and 999 mm 

1405 Density causes time to exceed max limit (479 min) 

1406 Time must be between 0 and 479 min 

1407 Time causes density to exceed max limit (999 min) 

1408 Consumption exceeds sector limit ({0} m³/h) 

1409 No valve found! 

1410 No valve data present 

1500 Decoder number must be between 1 and 255! 

1501 Decoder '{0}' already exists! 

1600 Course name '{0}' already exists! 

1601 Course name is not allowed to be empty! 

1602 Unable to delete non-empty course 

1602 Unable to delete course 



 User Manual  
 

 

Perrot Satellite ENG win7 State as of 03.04.2019 Page 179 / 180 

Error ID No. Description 

1700 Satellite {0} number {1} already exists! 

1701 Enter name for Satellite 

1702 Invalid satellite no! 

1703 Internal error: Satellite does not exist! 

1704 Unable to delete satellite - has decoders connected 

1800 Valve collection '{0}' already exists! 

1801 Empty valve collection name! 

1802 Empty valve name! 

1803 Unable to delete non-empty valve collection: {0}!' 

1804 Internal error: Valve collection does not exist! 

1805 Invalid course '{0}' specified for valve collection! 

1806 Invalid valve '{0}' specified for valve collection! 

1807 Valve '{0}' in collection '{1}' exceeds time limit (479 min) 

1808 Valve '{0}' in collection '{1}' exceeds sector limit ({2} m³/h) 

1900 Empty program name! 

1901 Program '{0}' already exists! 

1902 Unable to delete program in use '{0}'!' 

1903 Program contains no program lines! 

1904 Unable to delete step 1. Manual programs consists of at least one step! 

1905 Number of valves in step exceeds maximum {0}! 

2000 Unknown user '{0}' 

2001 User name '{0}' already exists! 

2002 Invalid password 

2003 Invalid privilege 

2100 Invalid filename 

2100 Exception: ‘{0}’ 

2201 Schedule not valid 

2202 Invalid schedule name 

2203 Schedule item not valid! 

2204 A schedule is running 

2205 Tries to use occupied pumpsystem 

2206 Schedule named '{0}' already exists 

2207 Schedule name can not be empty 

2208 Selected course not valid 

2209 Selected program not valid 

2300 System error: Communication timeout on satellite {0} -- please check cable! 

2301 System warning: Bidirectional decoder {0} at satellite {1} reports flow while closed! 

2302 System warning: Bidirectional decoder {0} at satellite {1} reports {2}! 

2303 System error: Number of bidirectional decoders at satellite {0} exceeds limit! 

2304 System error: Satellite {0} reported line errors! 

2305 Weatherstation: Rain on opener at satellite {0}! 

2306 Weatherstation: Rain on closer at satellite {0}! 

2307 System error: Measured flow at pumpsystem {0} exceeds threshold ({1:0.0})! 

2308 System error: Measured pressure at pumpsystem {0} exceeds threshold ({1:0.0})! 
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Error ID No. Description 

2309 System error: Measured wind speed at satellite {0} exceeds threshold ({1:0.0})! 

2310 System error: Measured XY value at satellite {0} exceeds threshold ({1:0.0})! 

2311 System error: Measured frequency 1 value at satellite {0} exceeds threshold ({1:0})! 

2312 System error: Measured frequency 2 value at satellite {0} exceeds threshold ({1:0})! 

2313 System error: Irrigation stopped --- Irrigation error timeout ! 

2314 System warning: Bidirectional decoder {0} at satellite {1} reports no flow while open! 

2315 System error: Error on either opener (S3) or closer (S4) prevents irrigation! 

2401 Hydraulic group flow is lower than hydraulic sector flow for hydraulic sector: {0} 

2402 Flow capacity is to low 

2403 DataSlinger version of SVG document not correct 

2404 SVG conversion failed 

2405 SVG file is not valid 
2406 Max {0} is allowed for 'Valve overlap/delay' 

2407 Min {0} is allowed for 'Valve overlap/delay' 

2408 Max {0} is allowed for 'Valve overlap/delay manual programs' 

2409 Min {0} is allowed for 'Valve overlap/delay manual programs' 

2410 Time not valid 

2411 
Mean time used for calculating automatic valve flow must be greater than or equal to {0} 
secs! 

2412 
Mean time used for calculating manual valve flow must be greater than or equal to {0} 
secs! 

  

 
Warning ID Description 

Z. 313 Warning 

Z. 446 Warning: Irrigation parameter {0} exceeds threshold ({1:0.0}) 

Z. 447 Warning: Programs using pump in service 
 

 
 
 
 
 
 

We remain at your full disposal for any further information you may require! 
 
 
 

REGNERBAU CALW GmbH 
Industriestrasse 19-29 
75382 Althengstett / Germany 
Tel. +49 / 7051 / 162-0 
technik@perrot.de 
http://www.perrot.de 


